how to perform unspecific enzyme digestion

support
how to perform unspecific enzyme digestion hui-song pak  2021-05-28
 

Dear Skyline Team,
I would like to use Skyline to analyze immunopeptidomics DDA, DIA and directDIA (DIA-Umpire) data. I'm using the wizard to do it but I'm stuck at the creation and importation of fastA file. We usually use "unspecific enzyme digestion" for normal Discovery approach and I don't know how to do it especially for directDIA (DIA-Umpire).
Your help to overcome this would be great.

Thanks in advance for your help

Best

Hui Song

 
 
Brendan MacLean responded:  2021-05-28

Hi Hui Song,
Nonspecific enzyme digestion is fine for your peptide search, but I think it would be unusual actually accept fully non-cleaved peptides as potentially biologically interesting. Do you truly feel that is your case? You want to quantify any peptide at all that a search may find, even if neither end matches how your protease cleaved? May I assume Trypsin?

Many years ago when I was focused mostly on peptide spectrum matching of DDA MS/MS, I also used nonspecific cleavage, though, only as a way to increase the search space to gain more confidence in tryptic matches. Ludovic Gillet, a colleague at ETH and the first author on the SWATH MCP paper, swears that he is convinced that semi-tryptic matches contain biologically interesting information. I would at least grant that peptides with a single tryptic cleavage do seem to cause some of the MS/MS spectra seen in DDA runs.

The question is what then do you want to spend your effort attempting to quantify? Skyline provides easy support for including semi-tryptic peptides with the enzyme option named "Trypsin (semi)". If you need another semi-cleavage enzyme that is also relatively easy to define.

If you really, really want to include fully non-enzymatic cleavage, then you will need to use a Peptide List in Skyline. Which you can do through Edit > Insert > Peptides, directly pasting a list, using your spectral library from DDA - View > Spectral Libraries - Add button. You will want to go through the wizard without adding any files to import (template creation mode), add your non-enzymatic peptides afterward, and then use File > Import > Results (or Skyline Batch) to complete your analysis. I would still suggest that you should have pretty high confidence that you believe these peptides are in your sample.

Personally, I would just use the semi-cleavage option, unless you are planning on doing the work to prove your peptides to reviewers, which will likely eventually require ordering synthetic isotope-labeled standards.

Hope this helps. Thanks for posting to the Skyline support board.

--Brendan