How to open a spectra in skyline?

support
How to open a spectra in skyline? qwa227  2021-04-23
 

Hi, there:

I am new to skyline and have problem opening spectra that were collected elsewhere. Just wondering if you have a step-by-step instruction? Do I need any other file besides the spectrum RAW data file? I watched your educational online videos but still could not get it to work.

Thanks.

QJ

 
 
Nick Shulman responded:  2021-04-23
Skyline is a tool for quantifying mass spectrometry data by integrating chromatogram peak areas. Skyline is not a very good tool for looking at individual spectra. If you want to look at spectra in a raw file, we recommend using our tool called "SeeMS.exe", which gets installed when you install ProteoWizard.

What type of mass spectrometer did you use? Do you know what sort of data you collected?

A typical first experiment with a mass spectrometer would be Data Dependent Acquisition (DDA) where the mass spectrometer was told to collect MS1 scans and then select the largest peaks in those MS1 scans for fragmentation and identification with MS2.
If you want to get started with DDA data, I would recommend taking a look at the DDA Search tutorial:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_dda_search

If that tutorial does not seem helpful, you should tell us more about what type of mass spectrometer you have and what sort of data you collected. If you want to send us one of your raw files, you can upload it here:
https://skyline.ms/files.url

-- Nick
 
qwa227 responded:  2021-04-23
Thanks, Nick! I am doing PRM with heavy peptides spiked in. I was told that the spectra were collected on Q Exactive. I knew heavy peptides showing up well. I would like to see heavy and endogenous peptides simultaneously first before future heavy peptide titration experiment. However, both the person who generates the data and me are not familiar with skyline. I cannot load it correctly. I tried file/open, it asked for spectra library. I tried to type in all transitions manually, or import etc. Nothing seems to work. Just wondering if you got a step-by-step instruction. Thanks. QJ
 
Nick Shulman responded:  2021-04-23
I would recommend that you do the following steps:
1. Use "Edit > Insert > Peptides" to tell Skyline which peptides you are interested in.
2. Go to:
Settings > Peptide Settings > Modifications
and use the "Edit List" button that's in the lower half of that dialog to tell Skyline which isotope modification should be applied to your heavy peptides.
3. Go to:
Settings > Transition Settings > Full Scan
and tell Skyline how to extract chromatograms from your MS1 and MS2 spectra.
You can choose either "Count" or "Percent" for "Isotope peaks included" (or you can leave it as "None" if you do not want MS1 chromatograms)
You should choose "Targeted" for "MS/MS filtering acquisition method"
We recommend choosing "Centroided" for both the "Precursor mass analyzer" and "Product mass analyzer".

After you done all that, you are ready to extract chromatograms from your raw file.
The menu item to extract chromatograms from a raw file is:
File > Import > Results

-- Nick
 
qwa227 responded:  2021-04-25
Thanks, Nick! This is really helpful. I am able to open RAW files this way! So you are saying that even for Orbitrap instrument, you still choose "Centroided" for both the "Precursor mass analyzer" and "Product mass analyzer"? Do you need to open other Transition Settings info such as Instrument etc? - QJ
 
Nick Shulman responded:  2021-04-25
Yes, we recommend "centroided" for all high resolution Thermo instruments.
When you choose "centroided" on the Transition Settings Full Scan page, you are telling Skyline to use the centroiding algorithm that Thermo has implemented. Their algorithm does a better job of figuring out how much of which m/z was observed.

You might also want to look at the "Settings > Transition Settings > Filter" page in order to tell Skyline which precursor charges and product ion types and charges you are interested in.
-- Nick
 
qwa227 responded:  2021-06-28
Hi, Nick:

I was able to open the raw data as you suggested. However, although I am able to use "split graph" to show precursor and product ions separately in one window, just wondering what the commands are to put the heavy and light peaks in split view in one window with synchronized zoom?

Also, when spiking heavy peptides into more complicated samples, there are sometimes missing or more peaks of heavy peptides. Just wondering if some other parameters are also important, e.g., # of miscleavage, retention time window if use measured retention time, method match tolerance, mass accuracy, etc?

Thanks.
QJ
 
Nick Shulman responded:  2021-06-28
The things that get put into the split panes depends on what you have selected in the Targets tree.
There are four levels of things in the Targets tree:
Protein > Peptide > Precursor > Transition

If you have a Peptide selected in the Targets tree, then each Precursor (i.e. charge state and isotope label type) will be put into a separate graph pane.
If you have a Precursor selected in the Targets tree, then the precursor transitions will go in the top graph pane, and the product ion transitions will go in the lower pane.

I do not understand your question about missing or more peaks of heavy peptides. If you send us your Skyline document we can take a look.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

Alternatively, if you send us a screenshot of what you are looking at we might also be able to answer your question.
-- Nick
 
qwa227 responded:  2021-06-28
Following your suggestion, I was able to put light and heavy precursors in separate panels in the same window. But previously and miracle, I was able to do this for product ions. Just cannot reproduce that any more. Also, for some reason, the same spectra was somehow read differently this time, thus missing some heavy parent ion (see example in the attached file). I also attached a couple of screen shots for what I meant about the second quesiton.

Thanks.
QJ
 
Brendan MacLean responded:  2021-06-28
I think you could achieve what you show on page 1 of your PDF by making sure both View > Transitions > Split Graph and View > Transitions > Products are checked. Then you would get this type of split graph with only product ions, even when you have precursor ion chromatograms available.
 
qwa227 responded:  2021-06-28
Hi, Brendan:

Thanks. Tried it. Yes it worked, but only when there are only one pair of heavy-light parent ions under one peptide. That explains why it worked miraculouly for me last time. I happened to have only one pair at that time.

QJ
 
Nick Shulman responded:  2021-06-28
If you wanted to see the heavy and light chromatograms in separate panes, you would select the peptide "TEAPESKPGSSSSLSLR".
There would be four separate graph panes, for the 4 precursors under that peptide: charge 2 light, charge 2 heavy, charge 3 light, and charge 3 heavy.
Note when the panes get that small, you often have to hide the legend using the right-click menu item "Legend".
When the graph does not have enough room to display the legend, it ends up being blank and can be quite confusing. When that happens, you either have to make the window bigger or hide the legend.

Also note that your charge 3 heavy peptide has no product ion chromatograms. The reason for this is probably that Skyline did not find any MS2 spectra where the precursor 583.638 was selected. Let us know if you need help figuring out why that happened.

-- Nick
 
Brendan MacLean responded:  2021-06-28
If it is just for a quick one-off image you would like to capture, then you can remove the charge states you don't want showing in the graph, and then immediately click Undo (ctrl-Z) to bring them back. This has made me feel we should also expand our multiple selection handling to graph multiple selected precursors, as we already do for multiple selected peptides. That would allow you to click and ctrl- or shift-click in the Targets tree to select just a subset of precursors you want to see together in a split graph.
 
qwa227 responded:  2021-06-28
You are right, hide legend works this time!

For Nick, this is the same spectrum that Skyline was able to identify 581 (not 583) peak as the actual heavy precursor ion two months ago. It would be great if you can help figure out what happened. As it was not me who acquired the spectrum. I do not know what files to upload.

Thanks.
QJ
 
Nick Shulman responded:  2021-06-28
QJ,

You should send us your Skyline document and at least one of your .raw files.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

You can upload that .zip file and your .raw files here:
https://skyline.ms/files.url

--Nick
 
Nick Shulman responded:  2021-06-28
QJ,

Thank you for sending those files.
The problem is that you are applying two heavy modifications to the arginine residues in your document.
If you go to:
Settings > Peptide Settings > Modifications
there is a checkmark next to both "Label:13C(6)15N(4) (C-term R)" and "Label:13C(6)15N(4) (C-term R)".
Because of this, Skyline is adding 16 Daltons to the arginine residues.

You should uncheck the checkbox next to "Label:13C(6)15N(4) (C-term R)" so that only the other +10 modification gets applied.
This will change the m/z of that its incorrect value 583.638+++ to the new correct value 581.6313+++.

After you do that, you should go to:
Edit > Manage Results > Reimport
and Skyline will extract chromatograms for everything again, and your missing chromatograms will show up.
-- Nick
 
Brendan MacLean responded:  2021-06-28
As for the split graph, you need to give it enough vertical space to show everything you want to graph. One way to get more, as Nick suggested, is to right-click and click Legend to uncheck the Legend option and hide the legends which can consume considerable space. Another is to flip a 27" high-res monitor vertical, and yes, you can always stick with fewer precursors, which at this point requires you to at least temporarily delete some when you have too many.
 
qwa227 responded:  2021-06-28
Nick: Got it. I misunderstood the modification option: As I have different versions of labels for the same peptide, I checked the boxes for all labels without realizing that it actually puts all labels on the same peptide.
Brendan: Thanks for the suggestion. Will try that.
Cheers,
QJ
 
Brendan MacLean responded:  2021-06-29
Also, I have posted an issue that should eventually make it possible to achieve a split graph of a subset of precursors even when a peptide has many without requiring deletion and undo.

https://skyline.ms/issues/home/issues/details.view?issueId=821
 
qwa227 responded:  2021-06-29
Currently I am actually picking just 3-4 product ions for each precursor so that two light-heavy pairs can be displayed together. Yes it would be more convenient if one can select which pair(s) to display.

For the heavy isotope modification issue, how should I use skyline in terms of both display and quantification, if I have a run with different versions of heavy peptides spiked into the sample at different concentrations?

Thanks.
QJ
 
qwa227 responded:  2021-07-03
One more quick question: Where can I find instrument parameters such as resolution, m/z isolation width and injection time in skyline? I do not have another software at hand to open the spectra. Thanks. QJ
 
Nick Shulman responded:  2021-07-03
ProteoWizard has a tool called "SeeMS.exe" which can be used to look at the spectra in mass spec files.
You can install ProteoWizard from here:
http://proteowizard.sourceforge.net/

SeeMS.exe will allow you to see the precursor isolation windows.

I am not sure what the best way to see the other information. I usually use ProteoWizard MSConvert to convert the raw file to .mzML, and then open the mzML file in a text editor. (I usually use a program called "emeditor" to took at mzML files, since most text editors cannot handle files that are that large)

The QualBrowser from Thermo is the usual thing that people use to look at Thermo Raw files. I do not know where to install that from.
-- Nick
 
qwa227 responded:  2021-07-03
HI, Nick:

Thanks for your reply. Just tried proteowizard and was able to convert a raw file to mzML file and open it in emeditor. But there was so many stuff in the text that I could not be sure about those instrument settings.
I do not know if one can install Qual Browser by itself or if there is a free version just for viewing.
As the instrument parameters would be something easy to show, just wondering if skyline is considering having it?
Also, will you please give a hint how to use skyline for both spectral display and quantification, if I have a run with different versions of heavy peptides (same endogenous peptide) spiked at different concentrations into a sample?

Thanks.
QJ
 
Nick Shulman responded:  2021-07-03
You can also use a ProteoWizard program called "msaccess.exe" to output a table with the list of spectra which includes the ion injection times:
http://proteowizard.sourceforge.net/tools/msaccess.html

Skyline is not a good program for looking at spectra. You can see individual spectra by clicking on the points along a chromatogram, which can be useful for seeing whether anything went wrong during chromatogram extraction. But, if you want to look at spectra in a raw file in general, you should use ProteoWizard SeeMS.exe.

I am not sure that I understand your question. It sounds like you might be talking about "Isotopolog Calibration Curves" where different heavy labeled forms of the same peptide are spiked into a single sample at multiple concentrations, enabling Skyline to show an entire calibration curve from a single replicate. I am attaching a pdf showing how to use this feature in Skyline.
There is some more information about Isotopolog Calibration Curves in the Panorama documentation:
https://www.labkey.org/Documentation/wiki-page.view?name=panoramaQC#isotopologue

-- Nick