Skyline occupies 100 % of CPU during DDA search

support
Skyline occupies 100 % of CPU during DDA search m kuppusamy  2021-04-19
 

When I perform a DDA search using MS Amanda in Skyline, it occupies almost 100 % of the CPU, causing the computer to terminate the program and eventually crash. Please suggest how to rectify this.

 
 
matt.chambers42 responded:  2021-04-19

Hi,

Generally 100% CPU usage is a good thing when you're running an intensive application. That means it will finish sooner. But we could set it at a lower priority if we're not already doing so so that it doesn't interfere as much with the user interfacing with the operating system.

However using 100% of memory and/or crashing is something totally different. Is that what's happening? Simply using 100% CPU for a while definitely shouldn't crash the program, but it may make the computer appear sluggish.

If it's a crash, it would be helpful to know what settings you ran the search with and kind of data file you were running on.

-Matt

 
m kuppusamy responded:  2021-04-19

Thanks for the reply. I ran it on a windows server (2016) (Intel Xeon CPU E5-2690 v4 @ 2.60GHz) with 128 GB RAM and 56 Cores. I had 16 Human shotgun DDA files. MS Amanda search was standard with standard modifications and Trypsin digestion. The whole server gets stuck in the middle of the search, and I cannot remotely log in anymore. The only way to reaccess the server is to physically restart the server which I have no access to. Could this be due to the server overheating? A similar problem happened with another software and limiting the RAM usage resolved the problem. Furthermore, I just tried searching on my desktop today, and even though Skyline used 100 % of the CPU, it did not crash the system.

 
matt.chambers42 responded:  2021-04-19

Yes I can definitely see 100% CPU interfering with Remote Desktop, I've had that happen as well. That should be alleviated by setting a lower thread priority for MSAmanda or a lower process priority for Skyline (the latter is something you can do yourself with Task Manager, see attached screenshot).

I doubt it's server overheating. Can you try lowering the process priority before launching the search and see what happens during the search?

 
m kuppusamy responded:  2021-04-19

Thank you very much! I will try this but definitely not this week. I don't want to go to the IT guy daily and ask him to restart the server.