PRM tutorial question

support
PRM tutorial question tun-li shen  2021-04-12
 

I am new to Skyline. Tried to follow PRM tutorial but missing the BSA library (see attached Word doc) when open the BSA example...

 
 
Nick Shulman responded:  2021-04-12
It is very strange that you would see that message.

The file that Skyline is looking for is "bsa_consensus_final_true_lib.blib" which is in the same folder as the .sky file which you just opened.

You probably can push the "Browse" button and find the file "bsa_consensus_final_true_lib.blib" and you will be able to continue with the tutorial.

I am not sure what could be causing this different behavior for you? I wonder whether you might have done the tutorial sometime in the past, so that Skyline has remembered that this file used to be located in some completely different folder that is no longer there.
Or, maybe, there is something unusual about the folder that you have all of these files in. Are there any special characters in the folder name? Is the folder on your C: drive, or perhaps a network drive?

-- Nick
 
tun-li shen responded:  2021-04-12
The problem seems to be where Skyline try to locate these files. I manually moved the file solved the BSA.blib file problem, but got a similar message when I tried to import peptide search library (see attached).
 
Nick Shulman responded:  2021-04-12
Oh. I see.

The problem is that you were using Windows Explorer to browse the contents of the .zip file, and then you are opening the .sky file inside of the .zip file by double clicking on it. When you double-click on a file which is inside of a .zip file, Windows extracts that file to a temporary folder on your computer (C:\Users\adminadmin\AppData\Local\Temp\...)

What you need to do is go to the folder:
C:\Users\adminadmin\Downloads
and find the file "TargetedMSMS_2.zip".
You need to right-click on that file in Windows Explorer and choose "Extract All..." and choose a destination folder.

-- Nick
 
Brendan MacLean responded:  2021-04-12
Strange. What version of Skyline are you using? Skyline 20.2 is supposed to give you this message, when you do what Nick described:

---------------------------
Skyline
---------------------------
Opening a document inside a ZIP file is not supported.
Unzip the file Temp1_Study9p1_site_56A_5500_Blinded_20120425_Final_2013-09-22_19-12-41.sky.zip first and then open the extracted file Study9p1_site_56A_5500_Blinded_20120425_Final.sky.
---------------------------
OK
---------------------------

If what Nick describes happened to you with Skyline 20.2 or later, then we clearly need to make our code that catches this mistake more extensive to also catch it in your case.

Thanks for reporting your issue and documenting it so thoroughly. Can you use File > Open containing folder to see exactly where the .sky file Skyline is looking at is ending up, and send us a screenshot of the Windows File Explorer that command brings up on your system?

--Brendan
 
tun-li shen responded:  2021-04-13
see attached