IMS filtering on monoisotopic mass is not working

support
IMS filtering on monoisotopic mass is not working Felina H.  2021-03-24
 

Hi skyline team!

I have a question regarding IMS filtering. In my skyline file I extract the two highest isotopologes. When comparing the Total Area export from before IMS filtering and after IMS filtering, it is getting smaller as expected. But when looking at the Area export for the monoisotopic mass and [M+1], only the area for [M+1] is changing but not for the monoisotopic mass. I attached an exemplary screenshot for one compound. As you can see for both the monoisotopic mass and the [M+1] there are signals outside the IMS filtering windows. Shouldn't the area change for both m/z after filtering?

Best, Felina

 
 
Nick Shulman responded:  2021-03-24
Felina,

Can you send us your Skyline document and your raw file?

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

You should also send us one of your raw files. If your raw file one of those ".d" directories, you should package that directory into a .zip file and send it to us.
-- Nick
 
Felina H. responded:  2021-03-24
Hi Nick,

when I go to File > Share, I get this error:
---------------------------
Skyline
---------------------------
The document must be fully loaded before it can be shared.
---------------------------
OK More Info
---------------------------
System.IO.IOException: IonMobilityLibraryManager : GetIonMobilityLibrary(document) not usable and not none
   at pwiz.Skyline.SkylineWindow.ShareDocument() in C:\proj\skyline_20_2_x64\pwiz_tools\Skyline\SkylineFiles.cs:line 1185
---------------------------

Can I also create a .zip file containing the three files belonging to my skyline document (Skyline Document, VIEW File, Skyline Chromatogram Data)?

Best, Felina
 
Nick Shulman responded:  2021-03-24
When you open your Skyline document, does Skyline give you a warning about not being able to find a particular library file, and giving you the option to browse for it?
Sometimes if you choose the "open anyway" button, Skyline gets in a state where the document will never be fully loaded. You can usually fix the problem by going to "Settings > Peptide Settings > Library" and unchecking any libraries that you are not able to find.
In your case, it sounds like the problem might be with your ion mobility library, which you would get to at:
Settings > Transition Settings > Ion Mobility.

The advantage of "File > Share" is that Skyline puts all of the libraries into the .zip file in addition to the .sky, .skyd and .sky.view files.
If you can't get "File > Share" to work, then, yes, creating the .zip file yourself is always an option. Please try to also put in all of the library files (.blib, .imsdb, etc) that your Skyline document is using.

Whatever files you can send us will be helpful, and we will probably be able to figure out why Skyline is not fully loading your document, or we might have to ask you for more files.
-- Nick
 
Felina H. responded:  2021-03-24
I uploaded the raw file on the website you gave me under 210324_Felina. The skyline file is in the attachment. Thanks for your help!
 
Nick Shulman responded:  2021-03-24
Thanks for sending those files.

Which molecule were you looking at in the screenshot you sent us at the beginning of this support request?
-- Nick
 
Felina H. responded:  2021-03-24
It was the first one, AcCa 18:1
 
Nick Shulman responded:  2021-03-24
What makes you say that the Area is not changing for your [M+0] transition?

I tried turning off ion mobility filtering (by going to "Settings > Transition Settings > Ion Mobility" and choosing "None" for the Ion Mobility Library before importing two different copies of your raw data folder.

I definitely see different Total Area values when Ion Mobility filtering is on versus off (see attached screenshot).
-- Nick
 
Felina H. responded:  2021-03-24
That's interesting to see. I'll try to reproduce that. Maybe I made some mistake.
I exported a report before and after filtering, which I attached, and compared the areas. There I saw that in the export the Area for [M+0] doesn't change but for [M+1] it changed.
 
Felina H. responded:  2021-03-24
That's how it's looking for me in the skyline file
 
Nick Shulman responded:  2021-03-24
Can you send me the .sky.zip for that Skyline document with the "IMS" and "noIMS" replicates in it?

I will look at the intensities along the chromatograms and figure out whether ion mobility filtering was actually being applied, and that the correct chromatogram was being used to calculate each transition's area in each replicate.
 -- Nick
 
Felina H. responded:  2021-03-24
Here is the file I was looking at. Again thanks for the help.
 
Nick Shulman responded:  2021-03-24
The chromatograms in a .skyd file are identified by the full path of the raw file that they were extracted from, for example:
Y:\timsTOF\timsTOF_flex\Felina\210219_timsTOF_lipids_PASEF_pos\data\d\ESTD_10000_PASEF_pos_1_G-B9_1_201.d

When you tell Skyline to import results, Skyline first checks to see whether the file is already in the .skyd file, and, if it is, Skyline does not extract any new chromatograms, but, instead, uses the chromatograms that are already there.

This can result in unexpected behavior if you have changed your settings, and expect that "File > Import > Results" is going to give you chromatograms with new numbers. Instead, you get exactly the same chromatograms as you had before. (If you change settings and want to see different results, you should go to "Edit > Manage Results > Reimport").

If you want to have the same raw file in your Skyline document twice (because you want to compare what it looks like with or without ion mobility), you need to change the name of the raw file on disk, either by changing the name of the raw file, or copying it to another folder.

You can use the Document Grid to see what settings your chromatograms were imported with.
The "Chromatogram Ion Mobility" and "Chromatogram Ion Mobility Extraction Width" columns are available at:
Molecule Lists > Molecules > Precursors > Transitions > Transition Results > Chromatogram

All of the chromatograms in the file that you sent me were extracted without ion mobility filtering.

It is still weird that the area of your M+1 transition is different (27792768 vs 29474622) between your two replicates.
It looks like you manually adjusted the peak boundaries on those two replicates (which is why there is a purple rectangle on the chromatogram showing you where the original peak that Skyline chose was). I would need to know exactly how you adjusted the peak boundaries in order to figure out how this happened, but I guess just something was different.

In summary:
1. If you change your settings and want to see what the new chromatograms look like, you have to use "Edit > Manage Results > Reimport".
2. If you instead try to do "Edit > Manage Results > Remove" and then "File > Import > Results", you have to save in between removing the results, and importing them again. Otherwise, Skyline will not think there is any work to be done, and you will end up with exactly the same chromatograms that you had before.
3. If you want to compare chromatograms with different settings in the same Skyline document, you need to copy the raw file to a new name on disk, otherwise, Skyline will always show you the same chromatograms.

Hope this makes sense, and let me know if you think something else is going on,
-- Nick
 
Felina H. responded:  2021-03-25
Hi Nick,

thanks a lot! I considered your points and managed to import the files with and without filtering and had a difference in both [M+0] and [M+1].

For my original files I also managed to apply the filtering for all isotopologes.
I changed two things:
1. I had my IMS library in a different folder than the skyline file. Now I have it in the same folder.
2. I'm not sure if re-importing is working. I now changed the transition settings from no filtering to filtering, removed all files, and imported them again via File > Import > Results.

Regarding the peak boundaries. Yes, I change the peak boundaries for all files I import in skyline with via File > Import > Peak Boundaries. But as you said the change of the Area of the [M+1] in the previous file seems to be for some other reason.

Best, Felina