CE optimization _transition list export

support
CE optimization _transition list export Sandy_MRM  2021-03-23
 

Hi,
I am trying to optimize the collision energy for my peptide standards, but after exporting the transition list, I am getting very low values as attached in the file. I am also attaching skyline file

 
 
Nick Shulman responded:  2021-03-23
I think you forgot to attach your other file that had low values in it. All I see is your .sky file.

By the way, usually when you send us your Skyline document, you are going to need to send us a .sky.zip file. The .sky.zip file would contain the .sky file that you attached as well as additional supporting files such as extracted chromatograms, and libraries. (It didn't matter in this case, since your Skyline document does not have any supporting files since you have not yet extracted any chromatograms). The way to create a .sky.zip in Skyline is with the menu item "File > Share".

Files which are less than 50MB can be attached to this support request. If you need to send us larger files you can upload them here:
https://skyline.ms/files.url

-- Nick
 
Sandy_MRM responded:  2021-03-24
Hi Nick,

Thanks for your response. I am attaching the needed files here. I am trying to export CE values for Altis.
 
Nick Shulman responded:  2021-03-24
Sandip,

Can you attach your .sky.zip file? The .sky file that you attached has some results in it, so I am also going to need the .skyd file in order to be able to look at it.

When you use the menu item "File > Share" in Skyline, Skyline puts all of the necessary files into the .sky.zip file. Windows Explorer makes it difficult to see which file is the .sky.zip file. You can turn that feature off in Windows by using the "View > Options > Change Folder and Search Options" in Windows Explorer, and then uncheck the "Hide extensions for known file types" checkbox on the View tab of the Folder Options dialog.

By the way, which values are you saying are low? Is that something that we can see in the .csv file that you attached, or is it something that we can see in the chromatograms?
-- Nick
 
Sandy_MRM responded:  2021-03-24
Hi Nick,

I am optimizing collision energy for these peptides on Altis. When I am exporting transition list with CE values it gives some number which is in .CSV file attached which low compared to values in skyline file. I used instrument type as TSQ Quantiva and exported then it give appropriate values. I am not sure why...
 
Nick Shulman responded:  2021-03-24
Can you give an example of a number in the CSV file which is different than what it is supposed to be? (Even if all of the numbers are wrong, let us know one number than should be different).

I am not very familiar with how to do collision energy optimization in Skyline so it might be that someone else can give you a better answer.

One thing to keep in mind about collision energy in Skyline is that Skyline has no way of looking at a raw file and figuring of which collision energy was used. Skyline has to assume that the data was collected using a method whose collision energies were the values determined by the Collision Energy and Optimization Library settings at "Settings > Transition Settings > Prediction".

I see that you have a collision energy equation ("Thermo Altis") with a slope and intercept which I can see when I go to "Settings > Transition Settings > Prediction > Collision Energy > Edit Currrent".
I think you are also supposed to create an Optimization Library because Skyline needs a place to store the things that it learns about the optimal collision energy for all of your transitions.
-- Nick
 
Brendan MacLean responded:  2021-03-24
Thanks for the .sky.zip file. First, the data would be much easier to work with if you chose "Add one new replicate" when you import your optimization raw data files, since all 15 files seem to cover your intended targets just once.

You might also want to do the following:
- Refine > Advanced - Results tab - Remove nodes missing results - OK
- Refine > Advanced - Document tab - check Add, in Add label type choose "light" - OK

This will give you heavy and light precursors with only the transitions you measured on the Thermo Altis. Otherwise, it appears that there are transitions which were not measured during your optimization runs.

The problem appears to be in your "Thermo Altis" equations for CE, which I am guessing you attempted to train yourself. They are really far from what you ought to be using, which is likely the "Thermo Quantiva" equations, since that is the model closest to the Altis and it seems the values did not change enough for us to implement new equations for the Altis.

You have:
Charge/Slope/Intercept
2    -0.0014    -0.6625
3    0.0049    -3.6006

Where the Quantiva is:
2    0.0339    2.3597
3    0.0295    1.5123

Having negative slope and a negative intercept makes all CE valued either zero or negative.

Also, your optimization data is only valid when the Transition Settings - Prediction - Collision energy selection is the same as you used when you exported your method for collecting the data. If you change this setting between exporting your method and using the collected data, then your results will be incorrect. Perhaps you exported your methods using the "Thermo Quantiva" setting, which would explain why switching back to it makes your optimized CE values look reasonable.

So, return to the CE Optimization tutorial, and stick to the existing trained equations (probably Thermo Quantiva for you). If this is what you have collected, then simply continue using it.

It takes a lot more expertise to train your own equations, and at least 15-30 precursors of each charge state you wish to train.

Sorry for the confusion. Obviously, we would hope the tutorial made using this feature clearer.

--Brendan