QuaSAR and SProCop Problem

support
QuaSAR and SProCop Problem hatice akkulak  2021-02-15
 

Dear Skyline team,

I am trying to analyse my data through QuaSAR and SProCop tools; however, I am getting an error message all the time. According to the immediate window, there is a problem about some of the packages needed to use that tool. I tried to install these packages through R studio but I still couldn't get to use these tools. I tried to use these tools through other computers but I got the same error message. I don't know what to do. I'll be glad if you could help me. Thank you.

Best regards.

 
 
Tobi responded:  2021-02-15
Title: QuaSAR and SProCop and AVG-DIA Problem

Hi all,

just FYI also AvantGarde DIA has issues with packages. Just in case it helps I leave some text as attachment. It could that that it works again simply in some time from now, but Im not sure.

Best,
tobi

 
Nick Shulman responded:  2021-02-15

Hatice Akkulak,

The Quasar that is in the Skyline Tool Store uses an older version of R for which packages no longer seem to be downloadable.

Another Skyline user provided us with an updated version of that tool. You can the .zip file for the tool from the bottom of this support request here:
https://skyline.ms/announcements/home/support/thread.view?rowId=44145

After you have downloaded the .zip file, you can install it in skyline by doing:
Tools > External Tools > Add > From File
(We really ought to update the Quasar .zip file that is in the Skyline Tool Store. I will ask around and find out who can do that)

I believe SProCop is obsolete, and you would be much happier using AutoQC which you can get from here:
https://panoramaweb.org/home/wiki-page.view?name=autoqc_loader

Tobi,

The error that you are running into is

"ERROR: failed to lock directory 'C:/Program Files/R/R-3.5.2/library' for modifying
Try removing 'C:/Program Files/R/R-3.5.2/library/00LOCK-lifecycle'".

That sounds like a different problem. I would recommend rebooting your computer and deleting the file that it mentions "C:/Program Files/R/R-3.5.2/library/00LOCK-lifecycle".
-- Nick