Triple Dimethyl Modification not imported from MaxQuantSearch

support
Triple Dimethyl Modification not imported from MaxQuantSearch ida suppanz  2021-02-02
 

Hello,
as I have now been struggeling for three days on this problem, I hope that someone can advise me. I am using Skyline regularly for MS1 filtering of ICAT data which works very fine. Now I have a dataset with triple dimethyl labelling, that means light +28, medium +32 and heavy +36, respectively on each N-terminus and Lysine residue . I do manage to set the modifications in the peptide settings in way that the correct m/z values are present in my test fasta (see screenshot). However, every time I try to use the "import pepide search" function with the msms.txt generated by MaxQuant, these settings vanish. If I try to do the "import peptide search" first (without adding the fasta first, only with the settings), Skyline tells me that there are no transitions, although I clearly have the m/z values corresponding to the Light and Heavy label in my msms.txt (see screenshot). If I try to import the whole msms.txt (not just the peptide I am interested in) with settings that worked for my ICAT data, Skyline correctly informs me that I do have Carbamidomethyl [+57] on C, and and Dimethyl [+28] on K, but that the following modifications cannot be interpreted: K [+32] and K[+36]. When I try to add, eg C'2H'6 - C2H6 as a heavy modification on K, Skyline tells me that this modification already exists and I cannot add it.
How can I get the chromatograms in Skyline?
Ida

 
 
Nick Shulman responded:  2021-02-02
Can you send us your files? That would be your Skyline document, msms.txt, and if you have them mqpar.xml and modifications.xml.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document.
In addition to that .zip file, you should also send us your msms.txt, mqpar.xml (if you have one) and modifications.xml.

If those files are less than 50MB you can attach them to this support request.
Otherwise, you can upload them here:
https://skyline.ms/files.url

If "Import Peptide Search" is not working for you, you might have better luck doing the steps separately.

The first thing that Import Peptide Search does is build the library, which you can get to by going to:
Settings > Peptide Settings > Libraries > Build...

The next thing that Import Peptide Search does is the equivalent of "File > Import > FASTA". However, if you are doing the steps yourself, you might instead find it easier to go to:
View > Spectral Libraries > Add All

Adding peptides from the spectral library viewer instead of by importing a fasta file sometimes solves problems for people, but I imagine you will still be seeing the warnings you are seeing about some modifications not being interpreted.

We will probably be able to figure out what is going wrong if we see your Skyline document and peptide search results.
-- Nick
 
ida suppanz responded:  2021-02-02
Hello Nick,
thank you very much indeed for your quick response. I tried out your suggestions but I only manage to get the unmodified peptide in the library. I attached my files in the hope that you can make sense of them. Ida
 
Nick Shulman responded:  2021-02-02
I see that when you add your library to your Skyline document, Skyline gets rid of your peptide "FQEQNAALGQGLGR".
If you want to prevent Skyline from changing the set of peptides that you have, you can right-click on the protein ("sp|O74700|TIM9_YEAST") in the Targets Tree and choose "Pick Children".
In the picker window that pops up, click on the magic wand icon to unselect it. Then Skyline will know that you are going to be deciding which peptides to include for this protein.

By the way, I see that on your peptide filter settings at:
Settings > Peptide Settings > Filter
you set "Min Length" and "Max Length" to 14. I imagine that you did this so that Skyline would give you that one peptide. It's better to use the "Pick Children" menu item to choose peptides for proteins so that Skyline will know that those are the peptides that you want.

-- Nick
 
ida suppanz responded:  2021-02-03
Dear Nick,
I tried the "pick children" option for my peptide, but that did not do the trick. Somehow I only get the unmodified version of the peptide in my spectral library and not the modified, labeled versions. If I first build the library and later set the peptide settings for the triple dimethyl modifications there is the message "Chromatogram information unavailable" for every Rawfile, even if I then see the correct m/z value (light, medium or heavy) for the precursors. I also no not manage to get a Chromatogram for any other modified, labeled peptide I have in my MaxQuant Search. Here the info is always " the following modification could not be interpreted: K[+32], [K+36]". Does Skyline have trouble reading the modifications.xml? Should I try to rename the modifications in the modifications.xml to match the names in Skyline?
Ida
 
Nick Shulman responded:  2021-02-03
As far as I can tell, Skyline is correctly interpreting your peptide search results.
Your msms.txt does not contain a modified peptide.
That is, in every row, the value in the "Modifications" column is "Unmodified".

Is there a reason that you expect your peptide search results to contain a modified peptide? Is some other tool telling you that there is a modified peptide in there?
-- Nick
 
ida suppanz responded:  2021-02-04
Hello Nick,
thank you very much for looking into this. In my MaxQuant search triple dimethyl labelling is not defined as 6 different variable modifications, but as three different labelling states (in MaxQuant this is called "multiplicity=3"), that's why in the "Modifications" column it says "Unmodified". (Here it would only write Oxidation (M) as a variable modification if that would be present.) From the output file "evidence.txt" of the MaxQuant search (see screenshot) it is clear that peptide is present in three different Labelling states (0, 1, 2) with the measured m/z values for charge 2 at 758.9, 760.9 and 762.6 respectively, which corresponds to +28, +32, +36 added to the N-terminus. I can try to set up the MaxQuant search with 6 different variable modifications and check whether Skyline can interpret them as 3 different labelling states later on. However with my ICAT datasets I also always define ICAT-light and ICAT-heavy as labels (multiplicty=2) in my MaxQuant searches and in the output msms.txts I use for Skyline it says "unmodified" (or "Oxidation (M) if present) in the column "Modifications". In this case Skyline does not have trouble interpreting the modifications so this should in principle not be the issue here. What do you think? Ida
 
Nick Shulman responded:  2021-02-05
It looks like BiblioSpec usually does the right thing with the "Labeling State" column in msms.txt, but it does not properly handle N-terminal modifications.

I believe it does correctly handle modifications that apply to a specific amino acid (such as your "DimethLys8" modification which gets applied to "K"). It just doesn't know what to do with modifications that apply to the C or N terminus.

I will ask around and see if we can fix this.
-- Nick
 
matt.chambers42 responded:  2021-02-12
Hi Ida,

Thanks for the report and small reproducible example files. I committed a fix so it'll be fixed in the next daily.