chromatogram files disappearing

support
chromatogram files disappearing Christian F  2021-01-25
 

Opening previous experiments doesn't open chromatogram for processed data, and results in the file for chromatographic data being erased completely. The file is not in the recycling bin (indicating it wasn't deleted), but seems to have been wiped from the computer all together. This happened for three experiments in a row.

 
 
Brendan MacLean responded:  2021-01-25

Can you please be more specific, perhaps including screenshots of what you are seeing? Obiously, after 3 files experiencing a problem, I hope you are now dealing with copies of your files and not anything where you could lose work.

Sorry you are running into this problem. I hope you haven't lost much work. It must be fairly specific to your configuration, because it is the first we have heard of this. With your help, we hope it will be the last.

Thanks for reporting to the Skyline support board.

--Brendan

 
Christian F responded:  2021-01-28

Here is a video of the issue

 
Brendan MacLean responded:  2021-01-28

It seems that you forgot to attach the video you mentioned.

 
Nick Shulman responded:  2021-01-28
If you open a .sky file which does not have any replicates in it, Skyline will delete the .skyd file.

When you extract chromatograms, Skyline creates a .skyd file containing the extracted chromatograms, but Skyline does not save the .sky file at that time. If you manage to exit Skyline without saving the .sky file, then, the next time that you open that .sky file, Skyline will see that it does not need its .skyd file, and Skyline will delete the .skyd file.

We would recommend that you tell Skyline to extract chromatograms again by going to:
File > Import > Results.

If you're worried about losing your manually adjusted peak boundaries, then there might not be anything that anyone can do about that, because manually adjusted peak boundaries are stored in the .sky file.

If extracting chromatograms was really time consuming, and you would like to skip that time, then, what you can do is:
1. Make a copy of your .skyd file which you know contains your chromatograms
2. File > Import > Results
and tell Skyline to extract chromatograms from all your results files.
3. while Skyline is extracting chromatograms, you can save and exit Skyline.
4. Copy your .skyd file from step 1 back into the folder with your .sky file
5. Open that .sky file in Skyline. Skyline will notice that there is a .skyd file there which already contains all the necessary chromatograms.
After step 5, you might need to go to "Edit > Manage Results > Rescore" in order to actually see numbers in Skyline.

This behavior is a consequence of the fact that Skyline stores chromatograms in a separate file from the rest of your stuff, and it is nearly impossible to prevent all of the ways that two separate files can become out of sync with each other.

If you would like you can send us your .sky file and your .skyd file and we can make sure that what I'm saying is what's actually going on.

You might have a backup copy of your .sky file somewhere that really does have replicates in it. If you were to put that file next to your .skyd file, you will see that the .skyd file does not get deleted.
-- Nick