MPPARRReport tool not working

support
MPPARRReport tool not working roman koziy  2020-11-16
 

Hi,

I have constructed a library from DDA SpectrumMill search results in order to evaluate MS1 spectra. I further wanted to export the Skyline results into Agilent MPP software for analysis. However, whenever I try to run the MPPAPRReport tool I get an error message (please see attached). Could you please suggest what could be the problem?

Thank you very much for your help,
Roman.

 
 
Brian Pratt responded:  2020-11-16

Hi Roman,

May I see the Skyline document in question? Please use Skyline's File > Share > Complete menu item to create a .sky.zip file. You can upload to http://skyline.ms/files.url or we can arrange something private.

Thanks for using the Skyline support board,

Brian Pratt

 
Nick Shulman responded:  2020-11-16
That Agilent external tool reads through your Skyline document file (.sky) in order to figure out what modifications you have defined.
It sounds like the tool is getting confused about the same modification appearing twice somewhere.

I imagine that this might happen if you have the multiple heavy isotope label types at "Settings > Peptide Settings > Modifications" and the same modification is associated with more than one Isotope Label Type.

If you would like, you can send us your Skyline document. I can send that to the people I know at Agilent and make sure that they know about this bug.

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files.

If that .zip file is less than 50MB you can attach it to this support request.
Otherwise, you can upload it here:
https://skyline.ms/files.url

Are you using the MPPReport from the Skyline tools store, or did you get that tool from somewhere else? If you got it from somewhere else, can you send me the .zip file that you used to install the tool in Skyline?

-- Nick
 
roman koziy responded:  2020-11-16
Hi Brian and Nick,

Thank you very much for such quick response.

Please find attached the skyline file TEST.sky.zip. I have also uploaded TEST.sky.zip, created by roman koziy, description Roman Koziy TEST file by following the provided url.

The library was created based on samples which start with HS… (7 samples). HC1R0 was imported through file – import – results. I don't think I have any heavy isotopes selected.

I believe the MPPReport tool was installed from an Agilent CD. I will try to find it and send you the zip file.

Thanks,
Roman
 
Nick Shulman responded:  2020-11-16
Roman,

It seems that the MPPAPRReport tool fails if there is more than one modification defined that applies to the same amino acid.

In your Skyline document, you have the modification "Carbamyl (K)" and "Acetyl (K)", and they both apply to the amino acid "K".
It appears that in order to use the MPPAPRReport tool, you will need to remove one or the other of those modifications from your document.

That is, you can go to:
Settings > Peptide Settings > Modifications
and uncheck the checkbox next to one or both of those modifications.

**Then, it's very important that you SAVE the Skyline document.** The MPPAPRReport tool does its job by reading the .sky file from disk. If you have not yet saved your Skyline document after changing the modifications, the external tool is still going to run into the same it was running into before.

After you have removed one of those modifications and saved your Skyline document, I believe the MPPAPRReport tool will be able to run without error.

I will email the people I know at Agilent and make sure they are aware of this bug.
-- Nick
 
roman koziy responded:  2020-11-17
Hi Nick,

I have tried to remove one of the K modification, but it still didn't work. I also tried to remove all modification with the same outcome.

Please find attached the zip file of the MPP APR Report Tool we used.

Thank you, Roman.
 
Nick Shulman responded:  2020-11-17
Roman,

It looks like you're using an old version of the tool from 2015.
Attached is a newer version of the tool.
With this new version of the tool, all you need to do is remove one of those modifications on K.
-- Nick
 
roman koziy responded:  2020-11-17
Hi Nick,

I updated the tool and now it works. Thank you so much for your help!

Roman.