Problem library creation for cross-linking

support
Problem library creation for cross-linking tatianibl  2020-10-22
 
Hi,

I am trying to build a cross-linking library using an output created by proxl from plink 2.0. However, I am having a problem. Follow bellow the error message.

Thanks,
All the best.
Tatiani.

---------------------------
Skyline-daily
---------------------------
ERROR: No spectra were found for the new library.

Command-line: C:\Users\tatiz\AppData\Local\Apps\2.0\49BTDOGX.MMZ\O1B3EWR8.PN0\skyl..tion_e4141a2a22107248_0014.0002_e354297bfe67025e\BlibBuild -s -A -H -o -c 0.95 -i teste -S "C:\Users\tatiz\AppData\Local\Temp\tmpA7B.tmp" "C:\Users\tatiz\Desktop\Arquivos_desktop\sample_input\teste.redundant.blib"
Working directory: C:\Users\tatiz\Desktop\Arquivos_desktop\sample_input
---------------------------
OK More Info
---------------------------
System.IO.IOException: ERROR: No spectra were found for the new library.

Command-line: C:\Users\tatiz\AppData\Local\Apps\2.0\49BTDOGX.MMZ\O1B3EWR8.PN0\skyl..tion_e4141a2a22107248_0014.0002_e354297bfe67025e\BlibBuild -s -A -H -o -c 0.95 -i teste -S "C:\Users\tatiz\AppData\Local\Temp\tmpA7B.tmp" "C:\Users\tatiz\Desktop\Arquivos_desktop\sample_input\teste.redundant.blib"
Working directory: C:\Users\tatiz\Desktop\Arquivos_desktop\sample_input
   at pwiz.Common.SystemUtil.ProcessRunner.Run(ProcessStartInfo psi, String stdin, IProgressMonitor progress, IProgressStatus& status, TextWriter writer) in C:\proj\pwiz_x64\pwiz_tools\Shared\Common\SystemUtil\ProcessRunner.cs:line 62
   at pwiz.BiblioSpec.BlibBuild.BuildLibrary(LibraryBuildAction libraryBuildAction, IProgressMonitor progressMonitor, IProgressStatus& status, String& commandArgs, String& messageLog, String[]& ambiguous) in C:\proj\pwiz_x64\pwiz_tools\Shared\BiblioSpec\BlibBuild.cs:line 201
   at pwiz.Skyline.Model.Lib.BiblioSpecLiteBuilder.BuildLibrary(IProgressMonitor progress) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Lib\BiblioSpecLiteBuilder.cs:line 156
 
 
Nick Shulman responded:  2020-10-22
That error usually means that no spectra in your search result file passed the cut-off score that you had specified. The default cut-off score is 0.95.
You could try specifying "0" for the cut-off score value, and see if you get some spectra.

If you would like you could send us your proxl or plink files (we probably also need your raw or mzML files) and we could see whether BiblioSpec is misinterpreting what is in there.
Files that are less than 50MB can be attached to this support request.

You can upload larger files here:
https://skyline.ms/files.url

-- Nick