No chromatograms or spectra are reported for peptides with modified cys or met

support
No chromatograms or spectra are reported for peptides with modified cys or met caminha marcelle  2020-10-07
 

Hi,
I'm a new Skyline (20.1) user and I'm having difficulties analyzing peptides with cysteine carbamidomethylation and methionine oxidation. The spectra of peptides with cysteine only show up when I select carbamidomethylation as a variable modification, thus reporting them as from m/z without the expected mass differences; no chromatogram is shown in any settings. As for the peptide with methionine oxidation (as a variable modification), neither the spectra nor the chromatogram is reported. However, in both cases, the peptides are detected by the Comet search tool integrated into the PatternLab after either DDA or PRM method acquision. Could you, please, explain me how to solve this? Any advice is greatly appreciated.
Best regards,
Marcelle

 
 
Nick Shulman responded:  2020-10-07
I am not sure I understand your question. Can you send us your Skyline document?

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms and spectral libraries.

If that .zip file is less than 50MB you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

If you would like you could also send us a screenshot of what you are looking at.
-- Nick
 
Nick Shulman responded:  2020-10-08
Can you also send us your Skyline document?

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including spectral libraries and extracted chromatograms.

Are you saying that you had some peptides with chromatograms, and then you made a change to your Peptide Settings, and then the chromatograms disappeared?

If you change your settings such that the modifications on the peptides in your document change, you will need to extract chromatograms again. You can do this by going to:
Edit > Manage Results > Reimport

If you want to see what peptide sequences are in your spectral library, you can go to:
View > Spectral Libraries

-- Nick
 
caminha marcelle responded:  2020-10-09
Hi, Nick!
When I reimported the raw file, the chromatograms were shown, but the spectra didn't appear.
 
Nick Shulman responded:  2020-10-09
Thank you for sending me your .sky.zip.

When I go to:
View > Spectral Libraries
I can see that the peptide CTVEGGEGSSFFPPR++ is there, but it does not have any modifications on it.
That is, the spectral library says that the precursor mz is 785.3537 instead of the 813 that it would be if it had the +57 carbamidomethyl modification on it.

When I look in your file "teste.blib", I can see that your peptide identifications came from "20200924_Tripo_NP-40_FASP_unSched01_5ppm_Raw.ssl".
The .ssl format ("spectrum sequence list") is a plain text format which easy to write by hand or with a computer program. You can find more about that format here:
https://skyline.ms/wiki/home/software/BiblioSpec/page.view?name=BiblioSpec%20input%20and%20output%20file%20formats

My guess is that a mistake was made when writing the .ssl file, and it should have used the modified sequence:
C[+57]TVEGGEGSSFFPPR
instead of the unmodified sequence:
CTVEGGEGSSFFPPR

Here is a list of peptide search formats that you can use to build BiblioSpec spectral libraries:
https://skyline.ms/wiki/home/software/BiblioSpec/page.view?name=BlibBuild

You mentioned that you used Comet. If you also used Percolator, then you can use the Percolator result file to build your BiblioSpec library.

-- Nick
 
caminha marcelle responded:  2020-10-09
I just uploaded the zip file.
 
caminha marcelle responded:  2020-10-09
I'll look into it. Thank you, Nick!
 
caminha marcelle responded:  2020-10-10
Hi, Nick!
I checked the .ssl file and the peptides were correctly assigned with the cys and met modifications. I keep having the same problem with others raw files. Is there something else you can think of as the reason for this?
 
Nick Shulman responded:  2020-10-10
Can you send us your .ssl file and the spectrum file that goes with it (.mzML, .mzXML or .raw)?

You can upload it here:
https://skyline.ms/files.url

--Nick
 
caminha marcelle responded:  2020-10-10
Is it possible to delete the file I uploaded before? =)
 
Nick Shulman responded:  2020-10-10
I have now deleted the file that you uploaded before.

Our intention is to periodically delete all the files in that folder, but we never seem to get around to it. The folder does get cluttered, but it is always easy to find newly uploaded files by sorting on the "Last Modified" column.
-- Nick
 
Nick Shulman responded:  2020-10-11
Thank you for uploading your new set of files.

I see that your .ssl files have the following columns in them:
file    scan    charge    sequence    modifications
where the "sequence" column contains the unmodified sequence and the "modifications" column contains the modified sequence.

The problem is that BiblioSpec only recognizes the column named "sequence" and that column is expected to contain the peptide sequence along with its modifications. The "modifications" column gets ignored because that is not a column name that BiblioSpec looks for.

What you should do is remove the "sequence" column from your .ssl file, and change the name of the "modifications" column to "sequence".

If you do that (like I have done in the attached file "fixed1.ssl") then you will see the correct modifications when you build a library from that file.

-- Nick
 
caminha marcelle responded:  2020-10-12
Thank you, Nick! I’ll try that. =)