Error Import Skyline Daily SureQuant data

support
Error Import Skyline Daily SureQuant data romeally  2020-10-02
 

I am developing a SureQuant assay using Skyline Daily and for the most part it is working fine, however sometimes randomly my .raw data files will not import. I can open them in Qualbrowser and they seem fine but they seem to randomly stop importing at certain scan numbers. Sometimes it fails early and sometimes it fails late in the chromatogram. I have attached the error message I get upon import. This was acquired on a Lumos instrument with software version 3.3 and the latest Skyline Daily using the triggered acquisition tab checked. Any suggestions? Appreciated!

 
 
Nick Shulman responded:  2020-10-02
The error that you are getting is:
error reading spectrum controllerType=0 controllerNumber=1 scan=20342

This error is caused by a corrupted scan in the .raw file. If you look at that scan in Qualbrowser, you will see that the scan looks completely blank, but the reported total ion current of that spectrum is not zero.

What you need to do is use ProteoWizard msconvert.exe to create a .mzML file with that scan removed from it.
The commandline for msconvert.exe to skip over scan number 20342 would be something like:
msconvert.exe -v -z SureQuantRetinoid_Heavy+Light_Lumos_IC_NewMetNewSample-dilute1000x.raw --filter "peakPicking true 1-" --filter "index 1-20341 20343-"

(the -- filter "peakPicking true 1-" is there to tell msconvert to centroid the spectra. The other filter with the "index" is the one that causes it to skip over scan #20342)

It is possible that you may have more than one corrupt scan in the .raw file. If that is the case msconvert will give you a new error with a new scan number. Then, you will have to run msconvert with a different command line where the list of index ranges skips over this new scan number in addition to skipping over scan #20342.

When ProteoWizard reads a corrupted scan, that puts the process memory in a bad state, and it is necessary to exit Skyline in order to safely continue. This is why Skyline cannot simply skip over these corrupted scans, and they have to be removed before Skyline can process the file.

I hope this works for you. If you need more help, you can send us that problematic .raw file. You can upload that file here:
https://skyline.ms/files.url

-- Nick
 
romeally responded:  2020-10-02
Thanks Nick

     I tried to upload the .raw file and I got a message saying I don't have authorization to upload. So I am running this same method and most of the time it works fine, but then I randomly get this bad scan. One file it is scan 7000 something and another it is scan 40,000 something and some run just fine. I guess this is a Thermo issue, but I don't want to have to keep fixing my .raw files. I am still developing this method but will want to be running it on many samples and fixing these random corrupted files will be a pain. Have you seen anything like this before? We have two Lumos instruments and it has happened randomly on both instruments. I will email Thermo, but if you have any suggestions that are easier than manually fixing the corrupt files it would be appreciated. Do you know why I was refused access to upload the .raw file?
 
Nick Shulman responded:  2020-10-02
Yes, these sort of corrupt scans have been reported by many users. I think we may have a tool somewhere which will give you a list of all of the corrupt scans in a raw file. I will ask around and see if I can find it, and whether it exists in a form that is easy for someone to download.

You did successfully upload "OMEALLY_ScanErrorSureQuant.raw". I believe the error you were seeing might have something to do with uploading a file which is already there (although, I am not sure about that, because it also looks like you were able to upload that same file a second time and replace the original).
-- Nick
 
romeally responded:  2020-10-02
Thanks...yes I see it now is uploaded. So this corrupt scan is on the acquisition side I take it? I ran the method like 10 times the other day with no problem and then I did 5 runs last night and all had a corrupt scan in different places and different precursor masses. Is this just a random occurrence that has no fix other than post acquisition? Should I contact Thermo or are they aware of it? If so are they trying to fix the bug? So if I can find all the corrupt scans with your program I should use proteowizard in the command line to remove those scans and import the mzML instead of the .raw file. At least I'm not alone...
Thanks!
Bob