bibliospec error

support
bibliospec error dkueltz  2020-09-05
 

Hi Nick, Brendan,
I have used the integrated bibliospec for many years and never had a problem but now for some files the error below pops up when trying to build a new spectral library. I am using pep.xml + corresponding mzxml files generated in PEAKS Xplus for building libraries. DDA data from two consecutive runs that look similar in terms of peptide and protein coverage and file size give different results. One file works fine for library generation but the other throws this error. I tried this with Skyline v19, v20, and the latest daily. I also tried windows admin and regular user accounts - same result. There is no disk space issue either. I can upload an example pep.xml + mzxml file pair that works and another one that does not work if that would help troubleshoot the issue - let me know.
Thanks,
Dietmar
System.IO.IOException: Error occurred running process.

Command-line: C:\Users\dkueltz\AppData\Local\Apps\2.0\CHO9N7RC.HQC\PCZXTA8K.NOQ\skyl..tion_e4141a2a22107248_0013.0001_e50c2c68eab478d7\BlibBuild -s -A -H -o -c 0.95 -i t -S "C:\Users\dkueltz\AppData\Local\Temp\tmpA47.tmp" "D:\Spectral-Libraries\t.redundant.blib"
Working directory: D:\LR0013_Oremo-Kidney\PEAKS_mzID-mzXml_Export\PEAKS10P__LR0013_Oremo-Kidney_gradual2weeks_PEAKS PTM_42
at pwiz.Common.SystemUtil.ProcessRunner.Run(ProcessStartInfo psi, String stdin, IProgressMonitor progress, IProgressStatus& status, TextWriter writer) in C:\proj\skyline_19_1_x64\pwiz_tools\Shared\Common\SystemUtil\ProcessRunner.cs:line 62
at pwiz.BiblioSpec.BlibBuild.BuildLibrary(LibraryBuildAction libraryBuildAction, IProgressMonitor progressMonitor, IProgressStatus& status, String[]& ambiguous) in C:\proj\skyline_19_1_x64\pwiz_tools\Shared\BiblioSpec\BlibBuild.cs:line 186
at pwiz.Skyline.Model.Lib.BiblioSpecLiteBuilder.BuildLibrary(IProgressMonitor progress) in C:\proj\skyline_19_1_x64\pwiz_tools\Skyline\Model\Lib\BiblioSpecLiteBuilder.cs:line 144

 
 
Nick Shulman responded:  2020-09-05
Yes, it would be helpful if you could send us your pepxml and .mzxml files.

You can upload them here:
https://skyline.ms/files.url

-- Nick
 
dkueltz responded:  2020-09-08
Hi Nick,

I have uploaded two zip files. One contains pepxml+mzxml that works, the other one contains pepxml+mzxml from a very similar sample processed in the same way that throws the error. The file names are:
PEAKS10P__LR0013_Oremo-Kidney_gradual2weeks_PEAKS PTM_646.zip (works without problem)
PEAKS10P__LR0013_Oremo-Kidney_gradual2weeks_PEAKS PTM_42.zip (throws the error)

Thanks for checking this out!
Dietmar
 
Nick Shulman responded:  2020-09-08
Thank you for sending us your files.

BiblioSpec is choking on the % sign in your filename.
BiblioSpec is trying to output the message:
Loading .\LR0013%20Kidney%20105-1%20150ng_2-A,3_01_2790.mzxml.
but the particular way that BiblioSpec is trying to output that message gets stuck on that "%" sign.

I will try to find someone to fix this bug.
-- Nick
 
dkueltz responded:  2020-09-08
Hi Nick,

Thanks much for figuring this out. Some of my students have a space in their sample names, which then gets included in the file name as %20. We have a convention not to include spaces in sample names but sometimes they creep in anyway and once they are there it is impossible to remove them manually. Rerunning the samples is also not ideal if they belong to large batches that took a long time complete. The strange thing with this error is that (I think) sometimes the % seems to have no effect and sometimes it does cause the error. At any rate, it would be great if this bug can be fixed for one of the next daily updates.

Best,
Dietmar