peak integration

peak integration monasharar  2020-08-26

Good evening,

I could see that for samples if they have 4 min peak width for example, some of them all the peak appears
while for others there is a cut, so first min appears then the line stops in the middle.
Manual peak integration cannot do anything other than adjusting boards, while if I view TIC for the run I cannot do manual integration.
Can you please advice ?

Thank you

Nick Shulman responded:  2020-08-26
I am not sure I understand what sort of data you have.
Are these MS1 chromatograms extracted from spectra? Are you saying that these extracted chromatograms should be longer than they are, but Skyline is truncating them?

One of the reasons that Skyline might truncate your chromatograms is because of what you selected at:
Settings > Transition Settings > Filter > Retention Time Filtering
and you can fix this by choosing "include all matching scans".

Another reason that Skyline may truncate your chromatograms is if you have MS1 and MS2 transitions in your document for the same molecule. If Skyline sees that the extracted MS2 chromatograms are shorter than the MS1 chromatograms for the same molecule, then Skyline will truncate the MS1 chromatograms to match the MS2 chromatograms. The confusing thing is that Skyline will do this even if the MS1 and MS2 transitions are in completely different places in the document, but the molecules that the two set of transitions belong to have the same Molecule Name. The workaround for this would be to change the name of the molecule with the MS2 transitions to something else like "ADMA_ms2".

If you would like, you can send us your Skyline document and a few of your raw files and we can see what is going on.
In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms.

If that .zip file and those raw files are less than 50MB you can attach them to this support request.
Otherwise, you can upload them here:
-- Nick
monasharar responded:  2020-08-26
Thank you nick for your reply.
I double checked the settings you mentioned but I already included all matching scans
I uploaded file named calibrator has example of metabolites that is full in the calibrator and is getting cut on another sample.
for example ADMA 203.1503 m/z
thank you
Nick Shulman responded:  2020-08-26

It looks like you successfully sent me your two .raw files, but you did not actually send me your file.
(You did include a file called "share.skyl", but that is just a log file)

Can you try sending me your file again?
(If it's less than 50MB you can attach it to this support request).
-- Nick
monasharar responded:  2020-08-26
please find attached shared file.
I have another question, I'm trying to run samples with MS1 (no MS2), from transition settings I did set MS1 filtering as non and MS/MS filtering as non. but I still cant see data .
thank you
Nick Shulman responded:  2020-08-26

It appears that the problem is that your transition settings at:
Settings > Transition Settings > Full Scan > MS1 Filtering
you have "Isotope Peaks Included" set to "None".

When you have that set to "None" this tells Skyline not to look at your MS1 scans at all. Instead, Skyline tries to extract chromatograms for your precursors from whatever MS2 scans happen to have an isolation window that contains the precursor, and the signal you see is the intact precursor that made it into the MS2 scan.

Instead, you should set "Isotope Peaks Included" to "Count" and set "Peaks" to "1".

Then you should change "MS/MS Filtering Acquisition Method" to "None".

After you do this you can tell Skyline to import your results again (for example with Edit > Manage Results > Reimport) and then you will get chromatograms extracted from the MS1 scans, and the chromatograms will span the entire length of the experiment run.

-- Nick
monasharar responded:  2020-08-27
Dear Nick
This is amazing thank you I got the MS1
I still need to know about the peak integration why I can t see full peaks
thank you so much