Skyline not recognizing in house Labkey server as 'Panorama server'

support
Skyline not recognizing in house Labkey server as 'Panorama server' mlane  2020-08-13
 

Hi,
We're using Skyline-daily 20.1.1.175 and just set up new Community edition of Labkey so not sure if this is Labkey or Skyline issue. I can directly connect to Labkey server through browser, log-in fine and create Panorama folders, etc. However, when I try to add server to be recognized in Skyline, an error comes back on the url that it is not recognized as Panorama server.
See attached for url and error.

Thanks!
Monica

 
 
Nick Shulman responded:  2020-08-13
Can you send us a screenshot of what your labkey server looks like (including the address bar) in a web browser?

It might be that you need to add a "/labkey" onto the end of that URL:
https://labkey.gritstone.com/labkey
it might be that you need to use "http" instead of "https":
http://labkey.gritstone.com
or it might be that you need to specify the port number:
http://labkey.gritstone.com:8080/

or it might be some combination of the above.

Also, some browsers hide the "www." at the beginning of URLs in the address bar, so even though it might look like your web browser is on the page:
labkey.gritstone.com
it might be that the URL needs to be:
www.labkey.gritstone.com

(I believe if you copy the URL out of the address bar in the browser and paste it into notepad.exe you will be able to see the real URL).

-- Nick
 
mlane responded:  2020-08-13
Hi Nick,
Thanks for getting back to me. See attached screenshot. Displaying the complete url in the address bar does show the https://labkey.gritstone.com/project/home/begin.viewgritstone.com/project/home/begin.view?

Labkey version is latest Community edition 20.7. We even tried turning the new 'path first' default url setting off in the system settings to see if that changed anything (thinking that maybe Skyline only liked the old url patterns) but there was same effect. Our server runs on port 443 default port for HTTPS, so I tried including that and it still gives same error 'not a panorama server (I tried 8080 too, and it can't find that site...probably because not applicable to us). It tried with and without the 'context path', ie "/labkey and that didn't work either. Also, in combination with including the port (443 or 8080); did not work.

Monica
 
Nick Shulman responded:  2020-08-13
The way that Skyline is deciding whether that server is a panorama server is by requesting the page:

https://labkey.gritstone.com/project/home/getContainers.view

and Skyline is looking for a line that says:
  "type" : "project",

Let me know what you see when you send your browser to that URL.

-- Nick
 
Vagisha responded:  2020-08-13
Hi Monica,

I think this is related to this support request: https://skyline.ms/announcements/home/support/thread.view?rowId=41926.

The "home" project on your server (https://labkey.gritstone.com/project/home/begin.view?) most likely requires a login. If you change the permissions on the "home" project to make it readable to anyone (assign Site:Guests to the Reader role in the permissions UI) then Skyline should be able to recognize it as a Panorama server.

This is a bug in Skyline that I should have fixed by now. Sorry about that. Hopefully, I can include a fix in the next Skyline-daily.

-Vagisha
 
mlane responded:  2020-08-14
Hi Vagisha and Nick,

Adding Guests to Reader role fixed the issue. I had tried that yesterday to no avail, but our Guests account was disabled, so I had our IT re-enable it, and it works now.

Many thanks!

Monica