SMILES InChi in Reports

support
SMILES InChi in Reports Christina lucas  2020-07-27
 

Hi there,

maybe I am to lost in all the report possibilities...:)

In SM Mode, you can enter SMILES and Inchi/InchiKey, HMDB and all this...

If I want to add it to my Report, where can I find it in the Report Editor?
I had several guesses, thing what it might be in "Proteinlanguage" , like Proteinname for Molecule Name e.g., but Proteinsequence and so on did not work...

I would be very grateful for a tip :)
Best, Christina

 
 
Emmanuel responded:  2020-07-27

Hi Christina,

In the report customization, try to go to: Precursor Result > Precursor > Molecule and then select the descriptors that you need (HMDB, InChi, etc.)

Best.

Emmanuel

 
Christina lucas responded:  2020-07-27

Hi Emanuel, thanks for the quick reply!

I now understand why I ended up with proteins :)
If you want to Add a Custom Report, you can't choose between Molecule and Proteins, so you end up having a custom "Protein" report, where you have to "translate"...
So the only way for a new Molecule List is to save a copy and modify it to your needs?
And if so, is there a way to get samples names as column names with their area? So far I could not manage this...

Best, Christina

 
Emmanuel responded:  2020-07-27

Hi again,

I'm not a power user of reports but when you want to create a new report (File > Export > Report > Edit List < Add) you can select which interface you want to use (by default it's the Proteomics interface). Just click on the icon above the Preview button to access the SM interface.

Then you should have access to the HMDB InChi descriptors to create your custom report.

I quickly tried to import the HMDB and InChi descriptors of a small molecule through the Edit > Insert > Transition list menu. I made a custom report to output the molecule name, formula, HMDB and InChi but these last two column remain empty .... (I'm using the latest Skyline-daily release).

I guess we might need the help from the Skyline team :-)

Best.

E.

 
Brian Pratt responded:  2020-07-27

Emmanuel is on the right track - normally you just customize a report to add those columns (there is a helpful search tool in the report customizer for finding the columns by name).

Although it sounds like you have a document that's proteins and peptides? In which case, yes, we are not making it easy to access columns that we normally think of as being for non-proteomic molecules. Try switching to "Mixed interface" (using that button on the upper right of the Skyline window) and you should see different options for report custimization.

And it sounds like there may be a snag - Emmanuel, can you provide that Skyline document so I can have a look?

Thanks for using the Skyline support board (especially you, Emmanuel - we are a community!)

Brian Pratt

 
Emmanuel responded:  2020-07-27

Dear Brian,

The attached example does not work when I'm adding the HMDB, InChi descriptors to an already existing target/transition list (I'm overwriting the transitions and adding the descriptors and then re-importing the results).

However, if I start with a fresh Skyline document and add the transitions AND the descriptors simultaneously, it works nicely ... I can see the HMDB and InChi descriptors in my custom report.

Hope this helps troubleshooting further.

Best,

Emmanuel

 
Brian Pratt responded:  2020-07-27

Hi Emmanuel,

Can you describe the steps you took in a little more detail? When you say "I'm overwriting the transitions" do you mean you're using Edit>Insert>TransitionList? If so, may I see that transition list file?

Or are you adding the descriptors in the Document Grid window?

Thanks

Brian

 
Emmanuel responded:  2020-07-27

Hi,

When I wrote "overwriting the transitions" I meant that I'm using the "Edit>Insert>TransitionList" menu and I'm re-specifying the transition details like names, precursor/product m/z, charge, etc. Then, I'm displaying the 2 extra columns to input the HMDB & InChi descriptors and checking for errors before indertion.

I've attached a screenshot of the menu window to make it clearer.

Thanks.

E.

 
Brian Pratt responded:  2020-07-27

Thanks for the details.

That's the kind of change that you'd normally make using the Document grid, but I can see where "Edit>Insert>TransitionList" is a fairly intuitive place to try that. The problem is that "Edit>Insert>TransitionList" is intended for creating new transitions rather than editing them.

It should at least be issuing a warning that it's going to ignore a line because it would stomp an existing transition - I'll enter this in our developer tasks.

Thanks for bringing this to our attention.

Best,

Brian

 
Emmanuel responded:  2020-07-27

Thanks Brian for your explanations.

Could you then point me to the right direction/tutorial for editing such fields (HMDB, CAS, InChi, etc)?

Those fields seem to be greyed out when editing and adding them to the default Molecules report ...

Best,

Emmanuel

 
Christina lucas responded:  2020-07-28

Dear all,

thanks for help!
The Report now works
although if you go on Documentgrund - > Manage Reports -> Add I do not find it very clear that you have to go to the question mark to switch to small molecule. Even if you are in SM Mode, you end up having Proteins/Peptides Reports first if you click on "Add"

The issue "adding" things to the Transitionlist /Changing something, is anyway a miracle to me, even if you just change the name of the molecule via selecting the molecule -> right click-> modify the hole transition is gone.

Best, Christina

 
Brian Pratt responded:  2020-07-28

OK, the threads are getting a little tangled here but I'll try to draw them together:

Emmanuel: you are right, I see that those HMDB, CAS, InChi, etc values are read-only in the document grid. I think we just didn't think people would change them after the initial import. I'll see about changing that. So for the moment the only option is having them set properly in the transition list at initial import time.

Christina: I have no idea why that question mark is there, clearly it should be the same as the icon in the upper right of the main Skyline window. We'll fix that.

Christina: I'm not sure what you mean about "the whole transition is gone" - can you give some detail? It's true that the chromatograms for the transition are dropped when you alter the molecule's properties - from Skyline's point of view the molecule identity has changed so that chromatograms are considered invalid. Perhaps this is a bit pedantic when it's just a name change, but that's the logic currently.

Thank you both for these valuable interactions, this is how we make Skyline better.

Best,

Brian

 
Christina lucas responded:  2020-07-29

Dear Brian,

that I allready found out that changing something leads to an invalid molecule.
But even killing the Molecule List and the results and reimport everything does not help to get the transitions again.
Only starting a new Document then helps than. Is that also part of the "pedantic" view point?

Best,

Christina

 
Brian Pratt responded:  2020-07-29

Hi Christina,

Can you provide some screenshots to illustrate the problem you're having?

Thanks

Brian

 
Christina lucas responded:  2020-07-30

I think I found the problem myself.
Just from deleting results it does not get back it's valid state.

So everything fine!