Exporting user-defined reports from command line

support
Exporting user-defined reports from command line fcsigloch  2020-05-27
 

Hi,
I am trying to export a custom report from command line. I defined the report previously out of the GUI and can access it from there. However, when I try to run
SkylineCmd.exe --in=someFile.sky --report-name="MyResults",
I get the error: Error: The report MyResults does not exist.

I tried to fix the problem by running SkylineCmd.exe --in=someFile.sky --save-settings, but that did not help.
(However save-setings seems to have fixed a similar problem with a user-defined mProphet model. This can now be used for reintegration.)

How do I correctly export the report?

Greetings, Florian

P.S.: Sorry for posting at the wrong place at first!

 
 
Nick Shulman responded:  2020-05-27
SkylineCmd.exe and Skyline.exe use different saved settings, because that is how Microsoft .Net manages settings-- they are associated with the .exe that started up.

This is different from how SkylineRunner.exe works. SkylineRunner.exe runs Skyline.exe in a separate process, and that Skyline.exe sees the same settings as when you run Skyline.exe with the user interface.

But when you run SkylineCmd.exe, Skyline.exe gets loaded up in the same process, and so it does not see the report definitions that you had when you were using the Skyline user interface.

You should be able to get the report definitions in to be recognized by SkylineCmd.exe if you do something like:
SkylineCmd.exe --report-add <xxx>

If you want to use the Skyline user interface to change settings, and have those settings be the settings that you get when SkylineCmd.exe runs, I believe there is a way to accomplish this by temporarily renaming "Skyline.exe" to "SkylineCmd.exe", but it's a bit of a hack and I'm not sure whether it actually works.
-- Nick
 
fcsigloch responded:  2020-05-27
Thanks, Nick. `--report-add=MyResults.skyr` solved the problem.