Error importing Thermo Quantiva raw files

support
Error importing Thermo Quantiva raw files Simon11  2020-02-21
 

After changing our LC setup for our Quantiva, we can no longer directly import raw files into Skyline. We have to convert to mzXML first.

The error given is below:
Failed importing results file 'C:\Users\footes\Documents\Skyline\VBPB140220R1602
4S02.raw'.
[RawFileImpl::setCurrentController()] Instrument index not available for request
ed device
Parameter name: instrumentIndex

I checked the raw metadata for a pre-LC change file and a post LC change file and have attached the 2 dumps. Looks like the error is caused by the recording of the LC method 1st in the postLC instance, which is assigning an Instrument: nano3000. The preLC file doesn't record any LC info.

Thanks
Simon

 
 
Nick Shulman responded:  2020-02-21
Can you send us your Skyline document and .raw files?

In Skyline you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files such as spectral libraries.

You can upload that .zip file and your .raw files here:
https://skyline.ms/files.url

I am not sure what that error is supposed to mean. (If you do a Google search for that error message you can see that our automated tests ran into that error in the autumn of 2018, but I'm not sure that's helpful information for anyone).

Did you use ProteoWizard MSConvert to convert the .raw files to .mzXML? Usually, if Skyline was having trouble reading a .raw file, then MSConvert would get the same error (unless it was a completely different version of MSConvert). It would be helpful to know if you have a version of MSConvert that can read the file.
-- Nick
 
Simon11 responded:  2020-02-24
I also tried with latest version of Proteowizard msconvert and it fails with the same error.
So fails with both latest version of Skyline and Proteowizard.

I uploaded a raw file: Quantiva_file_convert_error.raw

Thanks
Simon
 
Simon11 responded:  2020-02-24
A colleague just informed me that this version ProteoWizard 3.0.19313.2868cf7d4 64-bit
does the conversion without an error.

Simon
 
matt.chambers42 responded:  2020-02-24
I think this is caused by a seemingly corrupt "A/D Card" detector with an "NC_Pump_Pressure" name. Trying to get a chromatogram from that detector in QualBrowser gives a blank pane. I've added code in pwiz to skip the controller type when this error happens, but I'm quite perplexed why this would have succeeded with 19313. The setCurrentController call was no different at that time. A fix will be in the next Skyline-daily, and probably the 20.1 patch as well.