timsTOF Scheduled PRM Data Import

support
timsTOF Scheduled PRM Data Import robwsprung  2020-02-19
 

Dear Skyline Team,

Thank you for your continued development of an excellent software package.

I am having trouble importing scheduled PRM data from a timsTOF Pro instrument. When I look at the results in Compass DataAnalysis, it appears that the method worked as expected - MS1 signals for the expected isotope labeled peptides are observed and MS/MS spectra are acquired at the retention times of interest. However, when importing into Skyline Daily (20.1.1.32) no precursor and no product ions are observed.

I've successfully imported other PRM runs from the instrument. Only this scheduled method is causing problems. Any insight you could provide would be appreciated. Thanks.

Robert

 
 
Nick Shulman responded:  2020-02-19
Robert,
Can you send us your Bruker data file?

You can zip up that .d directory and upload the zip file here:
https://skyline.ms/files.url

-- Nick
 
robwsprung responded:  2020-02-19
Hi Nick,

The file has been uploaded. Thanks.

Robert
 
Nick Shulman responded:  2020-02-19
Robert,

This problem was reported by another user:
https://skyline.ms/announcements/home/support/thread.view?rowId=43896

Skyline 19.1 was able to correctly read these Bruker files, but Skyline 20.1 and Skyline-Daily both end up thinking that all the spectra are blank.

I will ask around again and see if I can figure out what is going on. (I did not get any replies the first time I asked).
-- Nick
 
matt.chambers42 responded:  2020-02-20
Hi Robert,

Weird. I've never seen a timsTOF instrument produce the analysis.baf format. I've only seen it produce analysis.tdf and analysis.tdf_bin files. But the analysis.sqlite file does indicate it comes from a timsTOF. Perhaps the instrument produces BAF when it's not collecting in ion mobility mode? Because there's no way to get ion mobility information out of the BAF API. Can you see if the unscheduled PRM data you have has tdf and tdf_bin files rather than the analysis.baf file this one has? I've also sent a query off to my Bruker contact.

The problem with blank spectra Nick mentioned dropped off my radar. I've got a fix for that. But it may be a separate issue than the TDF/BAF mixup.
 
robwsprung responded:  2020-02-20
Hi Matt,

The unscheduled run does have analysis.tdf and analysis.tdf_bin files.

From the method configuration screen on the instrument, there is an ion mobility range when running the unscheduled method. However, there is no ion mobility parameter when running in the scheduled mode.

Robert
 
matt.chambers42 responded:  2020-02-20

My Bruker contact replied:

  • Actually you can turn the tims-device off in the timsTOF. I then runs as a "regular" ESI-Q-TOF: [BrukerTimsMode.png] in that case it writes .baf files to be compatible with our non-tims Q-TOFS (e.g. Impact). For proteomics it is rather unusual to turn the tims-device off. If you want to check for tims-off you can open the file microTOFQImpacTemAcquisition.method and look for the parameter “internal_SWCompatibilityUseIMS”. If that parameter is 0 the tims-device was turned off.

And checking your .method file, that is indeed what the setting was set to. So I'm not sure whether you meant to have TIMS turned off, but Nick is right that the reason this particular data isn't showing anything is because of the blank spectra bug. I'll commit a fix for that today which will be in the next Skyline-daily or you can get the bleeding edge tonight (this link will not have the fix yet but will later tonight):

https://teamcity.labkey.org/repository/download/bt209/lastSuccessful/SkylineTester.zip?guest=1

 
matt.chambers42 responded:  2020-02-20
Well that formatting didn't work. Sorry.
 
robwsprung responded:  2020-02-21
Hi Matt, Thanks for the tester file. I am able to import the scheduled PRM and view the precursors and product ions. Of note on the timsTOF Pro, currently it is not possible to use the tims device with a scheduled method. When importing a table of scheduled precursors, the instrument defaults to an "Auto MS/MS" mode with tims deactivated. Attempting to activate tims results in the method switching to an unscheduled "MRM" mode which discards the target mass list and time window information. As it stands, your patch should allow me to analyze our upcoming scheduled runs. I'll let you know how it goes. Thanks again for the quick turnaround. Robert