About Msstatas error

About Msstatas error Quanhuiwang  2020-02-10

Dear Skyline team,
I have successfully installed MSstatas from the tool store, but it doesn't work! When I tried to use it, an error would always be reported in the immediate window as I shown in the attached file. When I changed another data, the error is the same. I hope someone help find the reason. Thank you!

Quanhui Wang

Nick Shulman responded:  2020-02-11
I do not know what that error means and I have not seen it before.

The error that you are seeing is "package or namespace load failed for 'MSstats' in loadNamespace...". There are also some strange characters and it says "caTools".

You might be able to fix things by uninstalling R version 3.5.0 from your computer and installing that again and then installing the MSstats external tool in Skyline again.

They also might be able to help you if you ask this question on the MSstats support board which is here:

-- Nick
Eugene responded:  2020-02-16
Title: About Msstats error
Hi Quanhui

I had the same error and uninstalling and re-installing did not work. What worked was to download an older version of caTools (from CRAN - and installing the zip package from within R itself. You also have to install "bitops" which is a dependency. I did all of this from within the R environment. After this everything worked fine from Skyline and MSstats generated its output as expected.

Hope this helps.