MSstats error

MSstats error rbbsky123456  2019-12-11

Hi, everyone. I met a problem for MSstats analysis with both DIA and PRM data. Here is the error messages:
** Reading the data for MSstats.....
** Peptides, that are used in more than one proteins, are removed.
** Truncated peaks are replaced with NA.
Error in SkylinetoMSstatsFormat(raw, removeProtein_with1Feature = TRUE, :
** Please check precursors information. If your experiment is DIA, please remove the precursors. If your experiments is DDA, please check the precursor information.

Can't finish analysis.

Skyline version is daily(64-bit)19.1.338 and Msstats is install as external tools.



Nick Shulman responded:  2019-12-11
The MSstats external tool in Skyline does not allow you to have both MS1 (precursor) and MS2 (fragment) transitions in your document.

In order to use the MSstats external tool you will need to remove either all of the precursors or all of the fragments from your Skyline document.

-- Nick
rbbsky123456 responded:  2019-12-12
Thanks Nick. Do you mean in the transition settings , the ion types can only be y,b or p? Can I only remove precursors or fragments in Msstats input file? And how to do ? Thanks again.
Nick Shulman responded:  2019-12-12

The MSstats external tool uses a report in Skyline called "MSstats Input".
You can get to that report using the Document Grid. There is a "Reports" dropdown at the top of the Document Grid, and you can choose:
External Tools > MSstats Input

After you have selected the MSstats Input report, you can choose "Edit Report" from the Reports dropdown.
On the "Filter" tab of the Customize Report dialog, you can add a filter for the "Fragment Ion" column.
In the attached screenshot, I have added the "Does not start with...precursor" filter.

Once you have made this change to the MSstats Input report, it will affect the data that the MSstats external tool sees.
This is probably easier than actually deleting all of the precursors from your Skyline document.
If you later want to use MSstats with precursor data, you will need to change the report back to the way it was.

If you want to learn more about the Document Grid and reports, you should take a look at the Custom Reports tutorial:
-- Nick
rbbsky123456 responded:  2019-12-12

Thanks a lot for your detailed reply. The problem has been solved. Thanks again.