Unable to auto-calculate regression

support
Unable to auto-calculate regression michael plank  2019-10-22
 

Hi,

I`m trying to set up a targeted PRM method by applying an RT-predictor on a sample where I only measured the iRT peptides (Biognosys iRT-11) in the calculator.
When I go to Export: Isolation list and try to select 'scheduled', I get:
"Retention time predictor is unable to auto-calculate a regression. Check to make sure the document contains times for all of the required standard peptides."
All 11 iRT peptides are detected with good signal and when I look at only the standards in View> Regression> Score to Run, the regression looks fine.

The complete file is attached.

Thank you,
Michael

 
 
Nick Shulman responded:  2019-10-22
Michael,

I cannot get this error to happen. I tried:
File > Export > Isolation List
and I chose "Thermo Q-Exactive" and "Method Type Scheduled".

I was able to get an isolation list without error.

Are you sure that you attached the correct Skyline document? Most of the precursors in that document have no transitions under them. (All of the iRT standard peptides have transitions, but the normal peptides in the document have zero transitions).

Can you post a screenshot of what you're seeing?
-- Nick
 
michael plank responded:  2019-10-23
Hi,

thank you. I uploaded the right document, but interestingly I`m not getting the error anymore now either. (???)

What I`m trying to do with this document is essentially what is described in tutorial iRT-2.5: I acquired a sample with iRT peptides and targets under chromatographic condition A and built an RT predictor from this. Then I ran a sample of only iRT peptides under chromatographic condition B. The instrument method acquired tMS2 for both iRT and target peptides, even though only iRT were present in the sample.
I then loaded the results from B into a file that contained a targets-list with both iRT peptides and target peptides. I selected the RT-predictor from A and left the 'Use measured RTs when present' unticked to get a predicted RT for the targets.
At this point I tried to export the scheduled isolation list, which gave me the error mentioned above. I then manually deleted all the chromatograms from the target peptides, speculating that these may somehow interfere with the regression. This is the file that I sent you.

Now when I do the export from either of the files, I don`t get an error anymore, however in the case where the transitions are target chromatograms are present I get the full isolation list, in the case where I deleted them I get an isolation list of only the iRT peptides. I`m not getting why it is relevant if I have results from peptides that I only want to predict. Could you please clarify?

Thank you,
Michael
 
Nick Shulman responded:  2019-10-23
If I remove the replicates from your Skyline document then I get the error that you first mentioned. I wonder if that is what happened to you.

The reason that you need to have results in your Skyline document in order to export a scheduled method is that you have told Skyline to automatically calculate the slope and intercept.

That is, if you go to:
Settings > Peptide Settings > Prediction > Retention Time Predictor > Edit Current
the checkbox "Auto-calculate regression" is checked.

That means that Skyline needs to look at where the iRT standards were found in your replicates in order to calculate the best slope and intercept to use to convert between iRT score and retention time.

You can see what that linear regression looks like by going to:
View > Retention Times > Score to Run Regression

Then, you have to choose from the right-click menu:
Points > Standards
Set Threshold > 0.99
Calculator > 20191022_TEVNth1_tryp_calc

You get a graph that looks like the attrached picture and you can see that Skyline chose a slope of 0.20 and an intercept of 24.43.

If you want to export a scheduled method from a Skyline document which does not have any replicates in it, you should go to:
Settings > Peptide Settings > Prediction > Retention Time Predictor > Edit Current
and specify those values for the slope an intercept.

(We should probably change the error message so that if you do not have any replicates in your document, it says something about that rather than telling you that your iRT standards are missing).
-- Nick
 
michael plank responded:  2019-10-24
Hi Nick,

thank you.
When you say 'remove the replicates', do you mean 'Manage Results' and the remove the samples or clicking the arrow next to the precursors and then unticking transitions (the second is what I did, not the first).

Everything you are saying makes sense to me. I understand that I cannot remove the results from the iRT peptides as these are the basis for calculating the regression. But I still don`t see why I cannot remove the results from the target peptides (by which I mean the non-iRT peptides)?

Thanks again,
Michael
 
Nick Shulman responded:  2019-10-24
Yes, I was talking about Manage Results.

I would not expect removing non-irt-standards from your document would have caused the error message that you were seeing.

If you are able to get that error message again you can send us your new document and we can try to figure out what is causing it.
-- Nick