How do I limit the RT window when use 'Apply Peak to All' function

support
How do I limit the RT window when use 'Apply Peak to All' function qzhang31  2019-10-17
 

Hi there,
I am running MS1 filtering for a bunch of peptides, I have a standard with high concentration and every peptide's peak is properly picked. Then I am loading some data with much lower concentration of those peptides and I find that skyline will pick wrong peaks at a very different RT.

How do I tell skyline to just look at 1 min RT window within the peak in file A for all the other files?

Thanks!

 
 
Brendan MacLean responded:  2019-10-18

Can you provide some screenshots of what you are seeing? And your Transition > Full-Scan settings?

 
qzhang31 responded:  2019-10-19

Please see attached slidedeck

 
Kaipo responded:  2019-10-21

The "Apply Peak to All" feature tries to make reasonable guesses about which peaks match, but certain circumstances cause it to guess poorly. It currently uses a dot product of fragment ion abundance, along with retention time as the primary criteria; but a small weight is also given to percent peak area, which is likely the cause of failure here.

Unfortunately at the moment this algorithm has no parameters, so its results can't be changed. I've opened an issue for this to make improvements in the future.