Peak picking within a specified retention time range.

support
Peak picking within a specified retention time range. wangqingok  2019-09-11
 

I have manually selected peaks corresponding to my target peptides in several reference samples and I have figured out my peptides' relatively stable and reproducible retention times. And I have 200 more samples to analyze. I know I could export and import peak boundaries to my future analysis when I want to quantify these peptides, but I found that for some peptides where a significant amount of noise signals are very close-by the target peaks, the quantification results are far off and the rentention times are not that reproducibly where to specify a fixed window for peak boundaries will have a lot of false positive signals being integrated and counted into the abundance. Therefore, I do want to also have skyline pick the peaks, but only within those predefined retention time windows (~ 2 minute windows) that I could manually get. Is there a way of doing this? Thank you so much for your help!

 
 
Brian Pratt responded:  2019-09-11

You might want to look at setting "Explicit Retention Time" (and window) using the Document Grid.

This is currently taken as a very strong hint for Skyline's peak picking: Skyline will prefer a peak in that explicit RT window but will still pick a nearby peak if nothing is found in that window. That's not quite what most users want, so I've recently made a change for the next Skyline-Daily such that we just won't pick a peak at all if nothing suitable is found in the explicit RT window.

Thanks for using the Skyline support board!

Brian Pratt

 
wangqingok responded:  2019-09-12

Hi Brian,
Thank you for your rapid response! Where could I find the place to input/import the "explicit RT window" values? I checked your previous post, and was trying to find this function in Edit->Insert->Transition List, but there are only 5 columns in that dialogue/table, they are "Peptide", "Precursor m/z", "Product m/z", "Protein Name", "Protein Description". Can you help let me know how to enable the explicit RT window function or where to find it? Thank you so much!

 
Brian Pratt responded:  2019-09-12

It's a two step process, unfortunately. You'll have to insert that information via the Document Grid after importing the transition list.

 
wangqingok responded:  2019-09-12

Hi Brian, Thank you for your response! I went to the "Document Grid" under "View", and there you could put that column in and basically changing the format of the report. But How to put my pre-curated "Explicit Retention Time Window" value for each peptide in to allow the software re-do the analysis? Can you help further? It just changed the format of the report exported, but I have no clue how to import such retention time values into Skyline to allow the software to pick peaks from. Thank you so much for your great help!

 
Brian Pratt responded:  2019-09-12

You can copy+paste those values right into that column of the Document Grid. Pretty cool! Nick Shulman has done wonderful work in that area of the Skyline code.

 
wangqingok responded:  2019-09-12

Hi Brian, that is not an issue to copy and paste, the issue is what copy and paste just change the output of the report, but NOT to have the software redo the peak picking according to my specified, of course through copy and paste, retention time widow. Can you be more clear about how to actually use the "Explicit Retention Time Window" settings into the software peak picking, but not just changing the output format? Thanks a lot!

 
Brian Pratt responded:  2019-09-12

If I have understood your question, you will have to reimport the raw files to take advantage of the new Explicit Retention Time information. That's easily done using the menu item Edit > Manage Results.

 
Brendan MacLean responded:  2019-09-15

Catching up on this late. I am not sure I see the type of acquisition you have used as your mass spect method. It is SRM/MRM, PRM, DIA or even DDA?

The issue is that I don't think the Explicit Retention Time window value is currently used in SRM/MRM (and PRM if you choose "Include all matching scans" for Retention time filtering) except for retention time scheduling of the method. So, if you didn't use it for generating the acquisition method for one of these types of acquisition, then you currently have no recourse for SRM/MRM (and must use retention time filtering for PRM). Skyline currently has no way of limiting peak picking to a sub-range of the chromatograms it has. So, whatever you see as chromatograms in the Skyline chromatogram graphs is what Skyline considers its range for picking peaks.

Please let us know if you have problems limiting the range of your chromatograms to the range you are hoping to use for peak picking (e.g. if these are SRM/MRM acquisitions).

 
wangqingok responded:  2019-09-16

Hi Brendan, Thank you for your response! I am not very familiar with the peak pick methods skyline is using to identify a potential peak, and we are thinking about the possibilities of truncating an SRM dataset with its raw data table to remove the data collected outside of our retention time window, and then import into skyline, this way the skyline is forced to just use the data within that retention time window. Is this type of data truncation doable with a 3rd party software? Some sort of mzXML editor can do this that you are aware of? Thank you so much!

 
Brian Pratt responded:  2019-09-17

You can certainly achieve that with msconvert and its filtering capability.

But have you tried using Explicit RT yet? It's really the place to start, much less trouble to deal with.