missing gene names, potential bug

support
missing gene names, potential bug Tobi  2019-08-30
 

Dear all,

when importing the attached fasta against the human proteome+isoforms with both filtering by gene or protein specificity, the filtering works as intended but the document grid shows empty fields for the Protein Gene (supposed to contain "HSPB1")

This is not a big deal, just so that you know.

Best,
tobi

 
 
Nick Shulman responded:  2019-08-30
Thank you for including that .sky.zip file.
When I look at the Audit Log for that file ("View > Other Grids > Audit Log") I am confused because it looks like you added a background proteome ("Human Proteome canonical UP000005640.protdb") to your Skyline document but the document does not have a background proteome.

It is supposed to be very difficult to get the audit log out of sync with what's actually in the document like this. Do you have any idea how this might have happened? (I also might be misreading the audit log).

Skyline has a complicated way of figuring out the metadata for proteins imported from FASTA files. Some of it involves parsing the ">" line in the FASTA file, but Skyline will also read information from the .protdb file, and fetch more information from some web services including uniprot.

When I import your FASTA file into a blank Skyline document, Skyline does correctly assign the gene name from the "GN=" part of the line in the FASTA file. However, it could be that if I had your .protdb file, Skyline might decide the gene name was something different.

Can you send me that file "Human Proteome canonical UP000005640.protdb"?
-- Nick
 
Tobi responded:  2019-09-02
Dear Nick,

rebuilding the background proteome solved the issue. I guess the original background was unavailable because of changed file paths. It looks that skyline attempted to read only the GN from the unavailable protdb while the other data was read from fasta headers (as you indicated). One might add that in such a case the GN is also read from headers, but this is not a big deal that would really need to be solved.

Thank you very much for the details on skylines behaviour, now it makes sense.

Best,
tobi