Close all chromatograms

support
Close all chromatograms pier-luc plante 1  2019-08-26
 

Dear Skyline Team,
is there a keyboard shortcut to close all chromatograms or is it possible to add one? I am working with more than 1500 samples and the close all button in the menu is difficult to access since it's located at the end of the sample list. Also, is there a way to disable opening all chromatograms when opening a skyline project? I am working with small molecules.
Thanks!

 
 
Nick Shulman responded:  2019-08-26
Yes, we should do something about the "View > Chromatograms" sub-menu when there are lots of replicates. When there are too many replicates, the regular menu items on there (Previous/Next Replicate and Close All Chromatograms) become too difficult to get to, so we should probably put the replicate menu items on a sub-sub-menu if there are too many of them.
I will try to fix this in an upcoming release of Skyline-Daily.

Skyline saves the state of all of your windows in a file with the extension ".sky.view".

I believe that if you do the following:
View > Chromatograms > Close All
and then
File > Save
then it will properly save the state of all of the chromatogram windows being closed, and the next time you open the document they will still be closed.

By the way, we always like looking at Skyline documents that push the limits of what Skyline can handle. If it is convenient for you, it would be helpful if you could send us your Skyline document so that we can make sure that Skyline is not doing anything inefficient that does not scale well with the number of replicates.

In Skyline, you can use the menu item:
File > Share
to create a .zip file containing your Skyline document and supporting files including extracted chromatograms and the .sky.view

If that .zip file is less than 50MB you can attach it to this support request.
Otherwise, you can upload it here:
https://skyline.ms/files.url

-- Nick
 
Brendan MacLean responded:  2019-08-26
Note that one way to get around the menu item placement issue is to learn menu item keyboard short-cuts. In this case, there is no key combination listed to the right of the menu item for View > Chromatograms > Close All, but every menu item can be learned as what are known as "keyboard shortcut chords" (true of most Windows software) by holding down the Alt key and following the underlined mnemonics which appear on the menus when you do this:

View = v > Chromatograms = o > Close All = a

So, you can simply learn the Alt + v, o, a keyboard shortcut chord and you never really need to look at the menu again for this item.

My personal favorite menu keyboard shortcut chord is Alt + f, a for File > Save As. Not many Windows programs seem to assign this a single key-press shortcut, but Alt + f, a always gets me there. It seems that the Microsoft Office team was conscious enough how ingrained these keystrokes have become for some users that they even kept many of these Alt + chord shortcuts working across the move from menus to the ribbon. Try Alt + f, a in Word or Excel with the modern ribbon.

But, of course, we should also make things easier for researchers like you with 1500 samples. Nice!

Thanks for your feedback.

--Brendan
 
pier-luc plante 1 responded:  2019-08-27
Thank you for the quick reply!
The Alt + v, o, a keyboard shortcut seems to work but Skyline crashed. I joined a zip file containing the skyline project files if you want to try it.
I also tried saving the session after closing all chromatograms on a smaller dataset and they re-opened. Maybe I am doing something wrong. I will try again.

We are working with very high-throughput methods (1 to 10 seconds per sample) for small molecule quantification using a limited number of transition per method (less than 10). Skyline seems to be a good option since it's the first software than can (relatively easily) load the 1536 samples from our test set.