CE method export for application in MassHunter controlling an Agilent 6490 instrument

support
CE method export for application in MassHunter controlling an Agilent 6490 instrument azad  2019-08-22
 

Hello support team,

I've searched the forum and exhausted my wit to find a solution, other than brut force which is borderline "manual" method development.

-I am running Skyline-daily 19.0.9.190 and MassHunter version B.07.01 build 7.1.7112.4 SP1 which is controlling an Agilent 6490 instrument.
-skyline file consists of 2458 transitions corresponding to 389 peptides
-transitions per peptide varies from 2 to 10
-My intention is CE optimization for every transition and I have only included heavy stable isotope labelled peptides in the file
-In the transition settings tab - collision energy tab - Agilent QQQ is selected
-Regression values exist for charge sates 2 and 3 but not 1 and 4, I do have the latter for a subset of the transitions in the file
-Step size is 3 and step count is 2
-When exporting methods the max concurrent transitions is set to 60 which results in 20 methods each containing ~600 total transitions
-When I attempt to load a method in MassHunter the Agilent6490 switches from online to offline
-To attempt to diagnose the problem I manually shortened the number of transitions for a method to 450 and was able to run the method. However, when I used the same approach for a subsequent method the instrument once again went offline.
-I manually looked over the transitions in excel to ensure the maximum concurrent transitions were actually 60 or less and appears they are.
-At this point I can't think of anything else expect to manually add transitions in the QQQ tab until the instrument goes offline and then scale it back and run the method. However, I would prefer to avoid this if there is a "smarter" solution.

Thanks in advance for your assistance.

Best,
Azad

 
 
Brendan MacLean responded:  2019-08-22

Hi Azad,
I have pointed out this thread to my contacts at Agilent, hoping they can provide a coherent explanation of what causes MassHunter to switch to offline mode. In the meantime, I guess I would suggest playing with the two settings in Skyline you have to control the transitions that end up in a scheduled method:

  1. Maximum concurrent transitions - try lowering it to 40, 20, etc. to see if something works better for MassHunter than 60
  2. Transition Settings - Instrument - Firmware transition limit - I am not aware of a hard transition limit on the 6490 but since you say that 450 worked and 600 did not, you might try setting this limit to 500, 400, etc.

It sounds like you have a pretty easy way to reproduce the problem, i.e. it is relatively quick to load exported methods and see if they cause offline mode. You maybe be able to find a pattern that allows you to set reliable limits before Agilent responds with a clear explanation. If not, we'll just have to wait for that response, since we have neither access to the MassHunter code that is enabling/disabling the online mode nor a 6490 instrument with MassHunter to test this on.

Hope you can find a way through. Good luck with your CE optimization.

--Brendan

 
azad responded:  2019-08-22

Hi Brendan,

Thank you for responding so promptly and informing Agilent.

In the meantime I'll proceed as per you instructions. However, not much wiggle room for reducing the concurrent transitions since some of the peptides would be monitored using up to ten transitions (up to 50 concurrent transitions per peptide using the current step size and count...). Maybe I'll have to lower the number of transitions per peptide, in the skyline file. Thanks again

Best,
Azad

 
Brendan MacLean responded:  2019-08-22

Hi Azad,
I will note that some of the other instruments (from Thermo and Waters) have limits on the number of transitions per "compound" and we have to do tricks to fool the instrument control software into accepting more transitions by making them look like different "compounds", e.g. on Waters each optimization step is given its own compound name so that a CE optimization method for a peptide with 10 transitions and 5 steps would end up looking like 5 "compounds" all with 10 transitions.

So, you might indeed try reducing the number of transitions or just start by filtering your method for peptides with lower numbers of transitions. You can use the Document Grid to do this as a bulk operation by using the "Transition Count" field to filter for precursors with larger numbers of transitions and then use the Delete button (red X) to delete all those precursors from your document. Then see if the resulting methods exported from Skyline can be loaded without causing the instrument to go offline.

Just save copies of your document with varying maximum numbers of transitions per precursor, e.g. 9, 7, 5 and see a certain maximum solves your problem.

Again without access to the MassHunter code, I am just guessing like you, but at least this adds a 3rd option to try for what the code might be keying off. I have never heard of this kind of limit with Agilent before, but...

--Brendan

 
Brendan MacLean responded:  2019-08-22

Hi Azad,
Agilent asks:

Are you seeing anything in the acquisition logbook along the lines of “Failed to download parameters to the instrument. Invalid XML String?” MHTQCLS-438.

Any chance you can upload files to reproduce the problem which I could pass along to Agilent? If they are under 50 MB, you should be able to attach them in a post to this thread, or you can upload them to:

https://skyline.ms/files.url

--Brendan

 
azad responded:  2019-08-22

I have some more information which I hope will help solve the issue.

To answer the question from Agilent, this is the error in the log: MSQQQ_1: QqQ fault detected: 5.8 Run parameter error.

I have attached an example method which will result in the instrument going offline.

Some new info since discussing this issue with you:

-As per your suggestion I tested whether a peptide with 10 transitions (50 transitions for step size and count of 3 and 2, respectively) with the same compound name would put the instrument into offline mode. I did so by exporting a CE optimization method (using skyline) as before = instrument did not go offline. Which I take it to mean changing the compound name may not solve the issue

-I also set the limit for maximum number of transition to 500 and exported 28 methods. Methods with concurrent transitions = 50 and total transition lower than 450 still put the instrument into offline mode.

  • Now if I change the delta RT in the QQQ from 1.2 min to 1 min, the issue is solved? AT least for 4 successive methods which I tried this with. As an example the file attached will put the instrument into offline mode. But if the Delta RT is lowered to 1 min (from 1.2min) the instrument remains online?

I can't thank you enough for spending your time on this, but thank you.

Best,
Azad