Issue with Edit->Refine->Advanced->minTransitions per precursor

support
Issue with Edit->Refine->Advanced->minTransitions per precursor Matthias  2019-07-18
 

Hi all,

I tried to import additional files into an already existing skyline analysis document.
Naturally, not all targets/transitions were found (see screenshot attached) in the new files which is why I was not able to use the library dotp when training the mprophet model.

According to a previous request (https://skyline.ms/announcements/home/support/thread.view?rowId=40632) I tried to use the advanced refinement settings and requesting for min 6 transitions per precursor (since I used also 3 MS1 precursor transitions).

However, the target list still contains peptides for which only 3 transitions were (only precursor transitions) were found and all the fragment transitions are missing.

This issue consists also in the latest skyline version (19.1) (tried it on another computer as well).

Does the Advanced -> min Transitions per precursor only check if at least 6 transitions are defined in the target list?
How can I filter those peptides out to enable library dotp in the mprophet model? (manually is not really an option since the document contains >150.000 peptides)

Thank you very much for any help

Best regards
Matthias

 
 
Brendan MacLean responded:  2019-07-18

Hi Matthias,
The refinement you are using does not check for associated chromatograms, it is just checking whether the precursors have enough transitions in them as they are in the Targets view, and the one you are showing has 9 transitions (3 precursor + 6 fragment) despite the fact that only the 3 precursor transitions have matching chromatograms (extracted from MS1 spectra).

You may be able to get rid of the fragment without chromatograms by using Refine > Remove Missing Results, which also has a checkbox in the refinement form Results tab. However, if the document contains a mix of results files where some have matching chromatograms for these transitions and some do not, then this operation may not get rid of those transitions. If it does, however, then following it with the minimum transitions operation should get rid of these precursors.

Finally, Nick added a delete button to the Document Grid which makes it possible to delete large numbers of targets based on somewhat arbitrary conditions which you define with sorting and filtering in the Document Grid. So, you could use a Precursor report to filter for all precursors where Library Dot Product is #N/A and then simply use Ctrl-A to select all of those and press the delete button (red X) to get rid of them all from your document. This approach doesn't require you to fully understand why those precursors lack the library dot product, which can happen for a number of reasons.

Hope these ideas help. If not and you upload your document (as a .sky.zip created with File > Share - Complete) to our file drop point:

https://skyline.ms/files.url

I should be able to provide you step-by-step instructions (likely using the Document Grid) that will solve your problem.

Thanks for posting to the Skyline support board with the informative screenshots.

--Brendan