issue tools installing

support
issue tools installing Wael  2019-07-17
 
Dear all,

I am trying to install the new AvantGardeDIA tool, but I always getting the following:

Downloaded failed.
Check your network connection or contact the tool provider for installation support.

System.Reflection.TargetInvocationException: Download failed.
Check your network connection or contact the tool provider for installation support. ---> pwiz.Skyline.Model.Tools.ToolExecutionException: Download failed.
Check your network connection or contact the tool provider for installation support.
   at pwiz.Skyline.ToolsUI.RInstaller.DownloadR(ILongWaitBroker longWaitBroker) in C:\proj\skyline_19_1_x64\pwiz_tools\Skyline\ToolsUI\RInstaller.cs:line 187
   at pwiz.Skyline.Controls.LongWaitDlg.RunWork(Action`1 performWork) in C:\proj\skyline_19_1_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 232
   --- End of inner exception stack trace ---
   at pwiz.Skyline.Util.Helpers.WrapAndThrowException(Exception x) in C:\proj\skyline_19_1_x64\pwiz_tools\Skyline\Util\Util.cs:line 1868
   at pwiz.Skyline.Controls.LongWaitDlg.PerformWork(Control parent, Int32 delayMillis, Action`1 performWork) in C:\proj\skyline_19_1_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 180
   at pwiz.Skyline.ToolsUI.RInstaller.GetR() in C:\proj\skyline_19_1_x64\pwiz_tools\Skyline\ToolsUI\RInstaller.cs:line 137


I have tride to install other tools such as MSstats and QuaSAR, and I am getting the same error msg.
I have ran some diagnostics for my internet, netwrok, R and PC and all seem to be fine.

Can you please inform me if there is anything I have to do to get these tools downloaded.

best regards
Wael
 
 
Nick Shulman responded:  2019-07-17
This might have been caused by a temporary outage of the R website. (There was such an outage that lasted two days a few weeks ago-- maybe there's been another outage).
You should try this again. The website might have started working.

AvantGardeDIA uses R version 3.5.2
Skyline tries to install R from this URL:
https://cran.r-project.org/bin/windows/base/old/3.5.2/

If you are still having problems, you might be able to work around the problem by installing R version 3.5.2 yourself. Skyline will notice that that version of R is already installed, and Skyline will go onto the next step which is installing the necessary R packages. Depending on what sort of network problems there are, that next step might either succeed, or might have the same error as you are already seeing.
-- Nick