DDA-light/heavy PTM on Lys

support
DDA-light/heavy PTM on Lys hye-young.h.kim  2019-07-01
 

I have DDA data with samples containing light/heavy PTM on Lys residue. I don't have internal stds. I would like to see relative ratio of these PTM.
Q1. Is it possible to plot light/heavy of MS1
Q2. Can I make Skyline not to make C-term Lys-PTM? Skyline makes correct modification with light-PTM but with heavy-PTM it always makes on C-term Lys. I have to manually remove all of them.

Thanks.
Hye-Young

 
 
Brendan MacLean responded:  2019-07-01

Hi Hye-Young,
Q1: Yes, this should be possible. In the screen capture you provided, it does not look like you have extracted chromatogram data for your heavy precursor of EIAQDFKTDLR. The colored dots to the left of the text indicate the targets you have extracted chromatograms for. And there is no dot for 628.3210+++ (heavy). Perhaps you added it after you imported your data? You may need to reimport your file to see both light and heavy.

Q2: Unfortunately, there is not a way to tell Skyline to modify only internal Lysine. You can tell it to automatically modify all Lysine (as it seems you have), or C-terminal Lysine (the opposite of what you want), but there is no way to say all Lysine but not C-terminal Lysine. The current solution is, as you have found, to manually turn off the C-terminal modifications. Do you have a lot of these? How inconvenient is it to do this manually? I have never heard of the workflow that produces this type of modification, and you are the first to ask for its support in the 10+ year existence of Skyline.

Thanks for the screenshots. Hope my answers help to clarify.

--Brendan

 
hye-young.h.kim responded:  2019-07-01

Hi Brandan,

Thanks for quick response. I re-did it and it worked. Still I couldn’t figure it out the way I want to plot (see attachede Q3). Is it correct if there is no idotp then no PTM precursor found? (Q4)
Yes. Every single C-term-K (tryptic peptide) are modified by Skyline and I have to remove them manually. I am testing now with a few proteins but eventually I will be using whole human proteome database. This leads me to Q5. I only want to import peptides with PTM associated with protein name to search the data. Is there a way to do that? I know how to import modified peptides only but wasn’t able to assign the protein name associated with the modified peptides.
Thanks. Hye-Young

 
Brendan MacLean responded:  2019-07-01

In the screenshot you sent, you can see that some of the precursors still are missing a dot (mostly green dots in your image). This means that for some reason, Skyline has not extracted chromatograms for them. I am not sure why, unless they were added after you last imported your raw data, which seems unlikely. I can probably be more helpful if you post your Skyline document (using File > Share - Complete) and a raw data file to our file drop point:

https://skyline.ms/files.url

You can get the graph you are looking for by selecting the peptide and not a single precursor in the Targets view. That is, if you select the peptide EIAQDFKTDLR you will get precursor-level chromatograms (unless you have View > Transitions > Split Graph checked). In this case, you will see 4 of them, one for each of +++, +++ (heavy), ++++, ++++ (heavy). If you still see chromatograms for every transition in 4 separate graph panes, then you must have View > Transitions > Split Graph checked.

If you really want to see a plot with only +++ - in red, and +++ (heavy) - in blue, you would need to delete the ++++, ++++ (heavy) precursors, potentially later to Undo that operation. I don't think there is currently a way to get a graph of multiple precursors other than the ones under a peptide when the peptide is selected. I could imagine this working, though, through multiple selection. That is I could imagine if you had +++, +++ (heavy) both selected and nothing else, that you might get the graph your are requesting. So, that is an interesting feature suggestion. Currently, however, we only give you a special graph for multiple selection when you have multiple peptides selected. With multiple precursors selected, we just show chromatograms for the one with the "focus" (dotted rectangle).

You should be able to assign protein names to added peptides by using the Edit > Insert > Peptides form. Also, you could just insert all your peptides and then use Refine > Associate Proteins to provide a set of proteins sequences (using FASTA) that the peptides will be mapped onto based on sequence matching.

Hope this helps. Sorry for the long response.

--Brendan

 
hye-young.h.kim responded:  2019-07-02

Uploading HYK_RAW data Zip file. Included a few other files I thought you might need. IDP were imported to Skyline after MSGF analysis to be assembled in IDPicker report. thanks.

 
hye-young.h.kim responded:  2019-07-02

I thought the first one was failed to be uploaded. I reloaded the same one. One can be removed. thanks. Hye-Young