Filtering Peptide min and max length not updating

support
Filtering Peptide min and max length not updating dawn dufield  2019-06-18
 

Hi,

I'm trying to filter my peptides in skyline after a digestion and it does not seem to update after I change the filter length. ie if it says 5 and I change it to 10, it does not remove the peptides that are shorter than 10.

Also when I chose 5 initially, it did not eliminate the ones shorter than 5. Is there anything specifically I need to do to get it to take my changes?

 
 
Nick Shulman responded:  2019-06-19
Make sure that "Auto-select all matching peptides" on "Settings > Transition Settings > Filter" is checked.

Also, if these short peptides are in your Spectral Library, then you need to make sure that "Pick Peptides Matching" on "Settings > Peptide Settings > Library" is either "Filter" or "Library and Filter", otherwise the filter settings will not be sufficient to remove the peptide from your document.

Another thing is that Skyline remembers for each protein whether you have manually changed the chosen the set of peptides for the protein. In Skyline-Daily we have added a new column in the Document Grid "Auto Select Peptides" which you can use to see whether any of your proteins are not in the auto-manage state. (If Skyline 4.2, you can see whether a protein is in the auto-select state by using the "Pick Children" menu item and seeing whether the magic wand button is selected.)

If you want to put all of your proteins back in the auto-select state, then you can go to:
(Edit) > Refine > Advanced
and check the checkbox that says "Auto-select all Peptides".
-- Nick
 
Brendan MacLean responded:  2019-06-19
Though, if your peptides are in a peptide list with no protein FASTA sequence, then Skyline just will never change peptide lists based on the Peptide Settings > Filter setting. It just assumes that you want what you put in that list. At the time you created the list, Skyline would have told you that it contained peptides not matching your filter settings and offered to remove those, but once they are in the document, Skyline won't offer to remove them based on settings changes. Probably we should ask in this case when you increase the minimum length or decrease the max length.

You can also use the Document Grid to get rid of even these peptides. You just need to create a customization of the Peptides view/report that contains Peptide Sequence Length. Then filter on that length column to show only the peptides you want to get rid of. Select all and click the delete button in the Document Grid toolbar (red X).

--Brendan