strange behaviour of unique peptides table checkmarks

support
strange behaviour of unique peptides table checkmarks Tobi  2019-06-18
 

Dear all,

in skyline daily 19, I used a fasta file containing several isoforms of a heatshock protein. To check for shared and unique peptides I created a proteome file from the fasta and I imported the same fasta to create the target list. When selecting all targets with CRTL+A and looking at the unique peptides table yields some unexpected results. Could you please tell me if I have an error somewhere or what might be going on?

For example Peptide EEGTQQR from protein Q8N241. In the target list and even in the table it is clearly stated that this peptides comes from this protein, in the table however there is no checkmark. Do I misunderstand the default checkmarks? Because I would expect them to occur by default in every case where a peptide matches a protein, but this is not the case. All setting were just set to default.

When clicking on a specific protein for unique peptides I havent found an error so far.

Looking forward a short reply.

Best regards,
tobi

 
 
Nick Shulman responded:  2019-06-18
Tobi,

Thanks for pointing out this bug. I will try to fix this in an upcoming build of Skyline-Daily after 19.1 is released.

When you bring up the unique peptides dialog, Skyline creates one row for each of the peptides in the proteins that you have selected in the Targets tree.
Each row of that grid is therefore associated with a particular protein and peptide. If the same peptide appears more than one selected protein (e.g. "EDGSLTIR") then there will be multiple rows in the grid with the same peptide sequence.

In the attached screenshot I have sorted the grid by peptide sequence, and you can see that for each of the rows for the peptide "EDGSLTIR" there is a different protein column that should be checked but in unchecked. In the screenshot, on the row with the highlighted cell, the "HSPB7" column is unchecked, whereas it's checked on all of the rows for that peptide. The reason it's unchecked on that particular line is because that's the line associated with the HSPB7 protein in your Skyline document.

This code all works great if you only have one protein selected when you bring up the Unique Peptides dialog. In that case, Skyline prevents the one protein you have selected from showing up in the grid, and therefore you never see that the checkbox is unchecked.

I will try to figure out the best way to fix this.
Thanks for reporting this.
-- Nick