Failure opening Skyline Session

support
Failure opening Skyline Session aline doerrbaum  2019-05-06
 

Dear Skyline Team,
I cannot load my Skyline session anymore.
The following error occurs: "Failure opening "C:[...]. Exception has been thrown by the target of an invocation." (also see screenshot attached).
We put a lot of work into checking and integrating the peaks already, so it would be great if there was a chance to rescue it.
An older version of the session, that I saved under a different name before curating the data, can be loaded without problems.
I'm using Skyline 4.2.0.19009 and Windows10.
Do you have an idea how to fix it?
Many thanks in advance!
Best,
Aline

 
 
Brian Pratt responded:  2019-05-06

I'm sure we can sort this out - can we have a look at the file itself? You can upload to http://skyline.ms/files.url, or get it to me privately if you prefer.

Best Regards,

Brian Pratt

 
Brendan MacLean responded:  2019-05-06

Can you also try this with Skyline-daily? It looks like an issue with the audit log reading code, which I thought we had fixed, but maybe the fix only made it into Skyline-daily. You are not quite using the latest Skyline 4.2 version which is 4.2.0.19072, but I doubt a fix for this issue was added between what you have and the latest. Still it would be nice to know whether Skyline-daily can open your file. You can get Skyline-daily, but clicking the green "Skyline-daily (beta)" button on the Skyline installation page.

 
aline doerrbaum responded:  2019-05-07

Dear Brendan and Brian,

Many thanks for your help! It seems that the problem is fixed.
I tried to load the session with the latest Skyline version (4.2.0.19072), but the same error occurred again. When opening it with Skyline Daily, a different error message occurred that suggested to rename, remove or delete the .skyl file. After removing this file, I can now open the session with Skyline Daily, but also with the normal Skyline version. All the changes we made before (peak integrations) are still there.
Just out of curiosity: What is in the .skyl file? And can we continue working with the rescued Skyline Session without that file?

Best,
Aline