Thermo Altis method

Thermo Altis method avizrosenberg  2019-04-03 07:13

When I try to export a method for a TSQ Alatis I get the following error.

System.IO.IOException: ERROR: Registry key (Software\Thermo Instruments\TNG\TSQAltis) not found. TSQAltis is not installed on this machine.

Any thoughts?

Brendan MacLean responded:  2019-04-03 08:18

Generally, for Thermo methods, you want to export them on the instrument control PC. This is because they use a multi-stream writer to write their methods which requires all of the component software to be present to write the entire method. That means you would need to create a fully comparable environment on your personal computer, including chromatography software, etc. in order to be able to merge a transition list with your template method from your instrument PC.

So, for Thermo especially, you really want to copy your Skyline document to the instrument PC (usually using File > Share to created a file or upload to Panorama and then download). Then open the file in Skyline running on the instrument PC and do the File > Export > Method there.

That said, we are currently having issues with exporting to Altis methods even once you get past this error message. I think I have a workaround ready to go out this week if you are running the 3.0 version of the software, but not the 3.1 version. I am working with Thermo on this issue.

I would still recommend you get past this error message and familiarize yourself with the required steps to export a method without errors, but currently on the Altis this will likely just give you a copy of your template without the transitions from the Skyline document, because of what we believe is a bug in the Thermo library we use.

Thanks for posting this issue to the Skyline support board.


ajstorey responded:  2023-08-17 09:22

I am encountering the same error when attempting to export an Altis method from the instrument control computer. Have there been any updates regarding this issue?

Nick Shulman responded:  2023-08-17 15:02
My understanding is that the error about the registry key was not considered a bug.

In order to export a Thermo method, certain software needs to be installed on the computer.
The Thermo .dll which we use looks in the registry under the key "HKEY_LOCAL_MACHINE\SOFTWARE\Thermo Instruments\TNG" in order to see what instrument software is installed on the computer.
You are not supposed to be getting this error if you are trying to export an Altis method on a computer with the correct software installed.

If you know how to use the Windows program called "Registry Editor", you could go look at the key "HKEY_LOCAL_MACHINE\SOFTWARE\Thermo Instruments\TNG" and see what values are there.
If you tell us what you see there, we might be able to figure out what is going wrong.
-- Nick
aaron storey responded:  2023-08-18 06:24
Thanks for helping me navigate the registry.

There is no "Thermo Instruments" subfolder in the HKEY_LOCAL_MACHINE\SOFTWARE folder. I'm guessing this information is somewhere else on my machine? If so, could I register this information at "HKEY_LOCAL_MACHINE\SOFTWARE\Thermo Instruments\TNG" as a workaround?

aaron storey responded:  2023-08-18 12:44
I did find a registry under "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Thermo Instruments\TNG" on a few other instruments.
ajstorey responded:  2023-08-21 07:56
I believe this information is registered at "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Thermo Instruments\TNG". What information from this folder is needed to create the instrument method?
Nick Shulman responded:  2023-08-21 21:19

The error message that you attached to your original post indicated that the software was looking for a key called "TSQAltis".

I see that you have a key called "TSQAltisPlus", but you do not have a key called "TSQAltis".
We have an Altis in our lab and I exported the "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Thermo Instruments\TNG" registry key into the attached file.

I am not the expert on method export. My guess is that this will not work for you until we add "TSQ Altis Plus" to the "Instrument type" dropdown in the Export Method dialog. I will ask my coworkers and find out what needs to be done.
-- Nick
Brendan MacLean responded:  2023-08-21 21:50
Skyline is trying to find the following DLLs:


One way around this is to find these DLLs on your system and put them in the following location relative to your Skyline.exe or SkylineDaily.exe:


I suspect that the failure is coming from the older versions of these DLLs that we release with Skyline, which at least gives us some hope of working even if we can't figure out where these DLLs live on your machine.

The current code for finding them doesn't us an instrument name:

                using (var tngKey = Registry.LocalMachine.OpenSubKey(@"SOFTWARE\Wow6432Node\Thermo Instruments\TNG"))
                using (var machineKey = GetFirstSubKey(tngKey))
                using (var versionKey = GetFirstSubKey(machineKey))
                    if (versionKey == null)
                        return null;
                    var valueObject = versionKey.GetValue(@"ProgramPath");
                    if (valueObject == null)
                        return null;
                    return valueObject.ToString();

It just looks at the first sub-key of TNG and then the first sub-key of that key, and then the value ProgramPath in there. From the screenshot you have provided that would be the TSQAltisPlus\3.4 key. Does the 3.4 key contain a value "ProgramPath"? If so, does the path it contains point to a folder that contains the DLLs listed above?

Skyline is trying to find your updated versions of these DLLs and use them, but it seems to be failing and then the older versions it has complain about not finding what they expect in your registry.

You can bypass all of this by copying your updated versions of those DLLs yourself. You can use the directions on finding Skyline.exe here:

And then just search for one of the DLLs above. Once you find them, just replace them with the ones installed for your instrument.

If you can provide us with any updated information on how to find a path to these files in your registry that might help us improve the code that looks for them.
aaron storey responded:  2023-08-23 14:07
I tried replacing the DLLs in the Skyline-64_22_2_0_527\Application Files\Skyline_22_2_0_527\Method\Thermo folder with the DLLs from C:Thermo\Instruments\TNG\TSQAltisPlus\3.4\System\Programs
This did not change the output.

I then tried adding new registry keys at HKEY_LOCAL_MACHINE\SOFTWARE\Thermo Instruments\TNG\TSQAltis\3.4
I added the ProgramPath and version strings and copied the values from the registry in the WOW6432Node.
It works now, I can export a method from a template file with the populated transitions from the skyline document.

I'm not sure of the side effects that this will eventually cause, but it does seem to function as a workaround.

Thanks for your help in finding a solution. Let me know if I can add any details to help improve the codebase.

Aaron Storey