Problems while installing Avant-Garde

support
Problems while installing Avant-Garde molloylab2019  2019-03-05
 

Hi everyone,
after reading the new paper about Avant-Garde I wanted to install it and try it for myself. When I tried to install it from the Skyline store I got an error after R 3.4.3 was installed and before packaged were loaded (see pic. "Error while installing R packages for Avant garde"). I then installed the tool via the external tool options which worked. I installed all the relevant packages through the R console using devtools (which worked just fine I could generate a params file using R). When I now go back and try to run any of the options in Avant-Garde (i.e param file) I get the following error (see pic "AvantGarde error messages"). Another thing I noticed is when I try the "help" option in Avant-Garde it opens the command promt but closes it directly after.
I tried re-installing Skyline as well as R with all dependencies which did not help. I don't have any problems with other tools (MSStats or SProCop) so I don't think it's an issue with admin privileges. Any help would be appreciated.
Additional info:
Skyline version 4.2.0 64-bit
PC Specs (see pic "PC specs")

Thanks,
Pascal

 
 
Nick Shulman responded:  2019-03-05
Pascal,

When you got the error message "Unknown Error installing packages. Output logged to the Immediate Window", there was probably some useful information in the Immediate Window.

You can right-click on the Immediate Window in Skyline and choose "Select All" and then "Copy" to copy all the text. That is a little easier to read than the screenshots.
The immediate window output that you posted in "AvantGarde error messages.PNG" are I think caused by whatever the original Error installing packages error was.

Can you try to get that "Error installing packages" error to happen again, and then send me the text from the Immediate Window? You might be able to get this to happen in Skyline by going to:
Tools > Tool Store
and pushing the "Reinstall" button for AvantGardeDIA.
However, it might be that Skyline already remembers that it installed those R packages for you, and therefore Skyline does not try to do it again.

If that's the case, then can you try installing Skyline-Daily and then see whether you get the same error trying to install AvantGardeDIA, and then send the text from the Immediate Window.

(also, it looks like the support board for AvantGardeDIA did not get set up right. That's a better place to ask questions like this since they go straight to the tool owner. I will try to get the support board fixed).
-- Nick
 
molloylab2019 responded:  2019-03-05
Hi Nick,
thanks for the quick response. I removed R 3.4.3 again and tried reinstalling to get the error (it always happens after R is done installing and while it tries to install the packages).
I attached the error message as well as the Immediate Window output, hope this helps.
Cheers,
Pascal
 
Nick Shulman responded:  2019-03-05
Pascal,

I think this is happening because your home directory ("C:\Users\Molloy Lab") has a space in it.
MSstats installs no problem in this scenario, but, for some reason AvantGardeDIA completely chokes.
This might be because AvantGardeDIA uses R version 3.4.3, and MSstats uses R 3.5.0, or it might be because of something else.

We will try to figure out how to fix this, but, for now, you might have to create a different Windows account in order to use this particular tool.
-- Nick
 
molloylab2019 responded:  2019-03-05
Thanks Nick, I will talk to our IT guys and let you know once I get them to create a new profile.
Cheers,
Pascal
 
S.Vaca responded:  2019-03-09
Hi Pascal,

I have updated Avant-garde to use R 3.5.2 instead of 3.4.3. I have tested it and the problem caused by the space in the directory path seems to be solved. You can install the new version of AvG from the Skyline tool or from the GitHub repository.
If you see another problem let us know.

Thanks,
Sebastian
 
molloylab2019 responded:  2019-03-11
Hi Sebastian,
great thanks! I've tried it and it worked for me :)
Cheers,
Pascal

ps: could you link me to a suggestion thread for the tool? Or do I just post that on the GitHub repo?
 
Brendan MacLean responded:  2019-03-11
I will note that all external tools have their own support boards on the Skyline website. You just go to the External Tools link on the Skyline main page and then click on the name of the tool to get to its details page. Then you click on the red "Support Board" button.

This request could have easily been the first post on the AvantGardeDIA support board. Future requests could certainly be posted there.

Thanks for providing feedback.

--Brendan