Line qaporter  2019-03-01
 
Hi, again. I have some more problem and question when it comes to the document grid, how do I get them to calculate the concentration if left it unknown and blank? Also, how do I form the line? Because it said I have an error that all the external standards are missing one or more peaks for my small molecule. I attached picture below to show the problems that are still occurring with settings and graph.
 
 
Nick Shulman responded:  2019-03-01
In the Document Grid, the calculated concentration is on the column:
Proteins > Peptides > Peptide Results > Quantification > Calculated Concentration

In order to get Skyline to draw a line on the calibration curve, you have to tell Skyline that at least one of your replicates is an external standard with a known concentration.
That is, in the Document Grid, when you are looking at the Replicates view, you need to change the "Sample Type" to "Standard" and you need to put a number in the column "Analyte Concentration". In your screenshot, you still have the Sample Type set to "Unknown" and the Analyte concentration is blank.

The error that you are seeing says that all of your standards are missing peaks. I believe this is technically true, since you have zero standards.
-- Nick
 
qaporter responded:  2019-03-05
Thank you for addressing so many of my question. Even though I have been asking for help on the wrong line. The line that I have been trying to make is not the linear regression or the calibration curve. But, it the RT and IRT line. Here is the link: https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3918884/ to the reference and some pictures below. The final and last question hopefully, is how do you make the line and that photo based on the given information about the product being small molecule target?
 
Nick Shulman responded:  2019-03-05
If you want to use iRT with small molecules, you have to use Skyline-Daily.
Skyline 4.2 only knows how to put peptides into an iRT database, but Skyline-Daily can do it for small molecules.

We only added support for small molecule iRT to Skyline-Daily a few months ago, and we are still figuring out exactly how it should work. Also, it might be confusing right now because Skyline uses the word "peptide" in a lot of places where "molecule" might make more sense.

Have you decided which molecules you are going to use as your iRT standards?

Do you have a Skyline document where you have extracted chromatograms for your iRT standards and some other molecules?

Then, using Skyline-Daily, you can go to:
Settings > Peptide Settings > Prediction > Calculator Button > Add New
and then press the "Calibrate" button and then "Use Results".
Skyline will choose some of your molecules to be the standards, and assign them iRT values between 0 and 100 based on their retention time.

Then, on the Edit iRT Calculator dialog, you can press the "Add" button at the bottom and choose "Add Results" and Skyline will add the rest of the molecules from your Skyline document and give them iRT values based on the retention time where there peaks were found.

After you have an iRT database, you can use the menu item in Skyline-Daily:
View > Retention Times > Linear Regression > Score to Run

If you only have one replicate in your Skyline document, then that linear regression will be a perfectly straight line, since the values on the Y-axis ("Measured Time") were used to populate the values on the X-axis (value from the iRT database).
But, if you have multiple replicates then you might be able to get a graph that looks like what's in that paper, with the observed times falling slightly off the line.

I hope this helps.
Let me know if you get stuck somewhere.
-- Nick
 
qaporter responded:  2019-03-06
I only have 4 standard small molecules, and it won't let me click ok in the edit iRT calculator, because an error pop up that says: Please enter at least 5 standard peptides. The picture is below. So, how do I get around that problem?
 
Nick Shulman responded:  2019-03-06
One way to work around that limitation is to add another molecule to your Skyline document which has the same chemical formula as one of your other standards, but give this new molecule a different Molecule Name.
--Nick
 
qaporter responded:  2019-03-06
Would you do this by inserting a new small molecule in the transition list?
 
Nick Shulman responded:  2019-03-06
Using "Edit > Insert > Transition List" is a good way to do this.

You can also make a copy of a molecule in the Targets tree by selecting it, and then choosing "Edit > Copy" and "Edit > Paste". That would leave you with two copies of the molecule, both of which have the same name. Then you can right-click on one of the molecules and choose "Modify", and change the name of the second molecule.
(This second technique does not work if your molecules just have a m/z and no chemical formula-- there seems to be a bug in the "Modify Small Molecule" dialog which causes Skyline to hit an exception if the molecule does not have a chemical formula. I'll try to fix this in an upcoming release of Skyline-Daily, but until then if you don't have chemical formulas, you are going to have to use the "Edit > Insert > Transition List" to get a copy of your molecule with some things different)
-- Nick
 
qaporter responded:  2019-03-07
So, I did the second technique and then I got an error in IRT calculator because it had the same smile code, how do I go back to the transition list and remove the smile, for the copy one? Also, when I tried to change the molecule the name, it doesn't show up in the IRT calculator use results and when I tried to add it, an error pops up about my cytidine.
 
Nick Shulman responded:  2019-03-07
Can you send me your Skyline document?

In Skyline, you can use the menu item:
File > Share > (complete)
to create a .zip file containing your Skyline document and supporting files, including your iRT database.

If that .zip file is less than 50MB, you can attach it to this support request. Otherwise you can upload it here:
https://skyline.ms/files.url

I can't tell what's going wrong in your screenshots because the message box is in front of the grid.
That grid has some logic in it which displays molecules with simple names if those names uniquely identify the molecule in your document. However, if you have multiple molecules with the same name, then Skyline falls back to displaying the molecule with a long thing with number signs and dollar signs in it.
-- Nick
 
qaporter responded:  2019-03-07
Here is the file and also, if you do fix the problem, could you please explain how you fix the problem?
 
Nick Shulman responded:  2019-03-07
I should have told you after you add a new molecule to your Skyline document, the new molecule will not have any chromatograms associated with it, so you won't be able to use it in the iRT calculator until you do a reimport.

You should use the menu item:
Edit > Manage Results > Reimport
and then Skyline will make sure that all of the molecules in your document have chromatograms.

That's probably the problem you're running into.

If that does not solve your problem, then you should send me your .raw file ("Standard.raw"), and I'll try to work through the steps that I'm telling you to do and make sure that they work.
-- Nick
 
qaporter responded:  2019-03-07
So, I did the steps that you said and it took everything off. So, I attached the raw file below and show the picture of the problem that arise when I did the steps.
 
qaporter responded:  2019-03-07
I cannot attach the raw file. But, these are results that came from during those steps.
 
Nick Shulman responded:  2019-03-07
I think this new error message means that you .raw file is not really a .raw file, or that the file is corrupted. (I can't be sure. There's a "more info" checkbox there that might give even more information).

I'll email you directly and see if you can send me that .raw file.
-- Nick
 
qaporter responded:  2019-03-07
So, when I get to the second part of the ppt and I do it own my on without that zip file, the green dot is not on the last one. I attached picture to this email, that show me following the powerpoint step by step.
 
Nick Shulman responded:  2019-03-07
Oops. I left out one instruction.
After you remove the results (Edit > Manage Results > Remove) you have to save the Skyline document.

Skyline keeps around the .skyd file on disk even when you tell Skyline to remove the results. Skyline does not delete the .skyd file until you actually save.
So, if you tell Skyline to import the exact same file again, Skyline notices that the .skyd file is already there, and then Skyline thinks it does not have any work to do.
(This didn't happen to me on my computer, since my directory names are all different than yours, so Skyline never thought I was trying to import the exact same file).
-- Nick
 
qaporter responded:  2019-03-07
So, I did the steps and these were the results. Another error occurs and stops the importing results. A picture is below.
 
matt.chambers42 responded:  2019-03-07
That's an odd error. Could you upload the RAW file so we can see what the Scan Filters are? I've never seen a blank scan filter.
 
qaporter responded:  2019-03-07
I can't upload the raw file to this response because it to big. But, I can upload this website link:https://skyline.ms/files.url.
 
matt.chambers42 responded:  2019-03-07
What is your region/language set to in Windows?
 
qaporter responded:  2019-03-07
It set in US/English.
 
Nick Shulman responded:  2019-03-07
qaporter,

Is it possible that the .raw file that you sent us before is different from the one that you are currently trying to extract chromatograms from?
That is, if you download the file:
https://skyline.ms/_webdav/home/support/file%20sharing/%40files/Standard.raw
and save it on your computer, can you extract chromatograms from it?

The .sky.zip file that you sent me before had some chromatograms in it? Do you have any idea why you were able to extract chromatograms before but you cannot do it now? Were you using Skyline 4.2 when you first extracted chromatograms and now you're using Skyline-Daily.
(It does not make sense to us that Skyline 4.2 would be able to read a .raw file that Skyline-Daily is unable to, but it would be helpful to know if that's the behavior your are seeing).

This is a mystery.
-- Nick
 
qaporter responded:  2019-03-07
Yeah. When I first extracted the chromatograms, it was in skyline 4.2, and now I'm trying to extract in the skyline daily, is that the problem?
 
matt.chambers42 responded:  2019-03-08
OK, this seems to be a 32-bit/64-bit issue. I'm able to reproduce the crash with 32-bit msconvert (which uses a different Thermo API). Try again with 64-bit Skyline.
 
qaporter responded:  2019-03-08
Is that still using the skyline daily program?
 
matt.chambers42 responded:  2019-03-08
Both 4.2. and -daily have 64-bit versions. Although if you have the 32-bit version, that might mean you're on a 32-bit operating system. Are you on an instrument machine? If so, you may need to move your data analysis to another (64-bit) computer until this is fixed. Sorry for the hassle. It has to do with the PDA/UV data in this file.
 
qaporter responded:  2019-03-08
I have two questions. The first one is how do I know which version I have or need to download? The second one is how do I know my computer the problem? The instrument machine I am using is the MS1 full scan filtering.
 
Nick Shulman responded:  2019-03-08
You can tell which version of Skyline you are using by using the menu item:
Help > About

If you are using the 64 bit version of Skyline, then the About Box will include "(64 bit)" in the version name. If you are using the 32 bit version of Skyline, there will not be anything extra in the version name.

You can install the 64 version of Skyline-Daily from here:
https://skyline.ms/project/home/software/Skyline/daily/begin.view?

You should probably uninstall the 32 bit version of Skyline-Daily that you have, since the entries on the Windows Start Menu for both flavors of Skyline Daily just say "Skyline Daily", with no indication of which one's for 32 and which one's 64 bit.
-- Nick