Exporting peak areas to compare multiple runs

support
Exporting peak areas to compare multiple runs lparsons  2019-02-15
 

I'm having a hard time doing this in 4.2.0.19009 as I used to in previous versions of skyline; in particular I'm not getting exported tables to come out in the format I'm expecting.
For example, if I have 6 MS files (A1, A2, A3, B1, B2, B3) that were read into Skyline against a list of transitions, and I'm trying to compare the peak areas of the same peaks across the 6 samples, I'm not getting the best table formatting for this. I would like to see a table that is roughly:
(mz)(rt)(area_A1)(area_A2)(area_A3)(area_B1)(area_B2)(area_B3)(sequence)(protein)(more_stuff)

But what I'm getting instead (by way of File -> Export -> Report -> Peptide Quantification, or File -> Export -> Report -> Peptide Ratio Results) looks more like
(sequence)(mz)(rt)(file_name)(area)(sequence)(protein)(more_stuff)

Where each peak is repeated on six consecutive lines. I would like to have each peak on one line with all of the observed areas on that line with it.

I looked at "Skyline Custom Reports" (https://skyline.ms/_webdav/home/software/Skyline/@files/tutorials/CustomReports-1_2.pdf) but it still generated a report where each peak was represented by multiple lines. In previous versions of skyline I was able to generate reports where each peak had just one line.

Any suggestions would be much appreciated.

 
 
Nick Shulman responded:  2019-02-15
It sounds like you have added some column to those reports which causes Skyline to give you one row per transition.
Here is a .skyr file containing those report definitions from a clean installation of Skyline.
You can import those definitions by doing:
File > Export > Report > Edit List > Import

If you need help figuring out which column does not belong there, then you can do:
File > Export > Report > Edit List > (select the reports you care about) > Share
to create a .skyr file with your report definitions, and if you send it me I can probably see what went wrong.

-- Nick
 
lparsons responded:  2019-03-01
Nick

Thank you for the response, I apologize for leaving this sitting so long. I don't see a file in your reply though, could you post it again? My skyr file is here with this message.

thank you
Lee
 
Nick Shulman responded:  2019-03-01
The following columns are causing you to get one row per precursor:
Total Area MS1
Total Area
Total Area Ratio

The "Total Area MS1" column that you have is from the Precursor Result.
The "Total Area" and "Total Area Ratio" columns are both from the Precursor Result Summary.

If you get rid of those three columns from the report, then you should be back to one row per Peptide and Replicate.
-- Nick
 
lparsons responded:  2019-03-01
Nick

Thank you for the reply. I must have missed something else in "Peptide Quantification" though as after removing those three I'm still getting a report with one line per observation of the peptide (hence in this case six lines per peptide, each listing its own AUC). Where else should I look?

thank you!
Lee
 
Nick Shulman responded:  2019-03-01
Oops. I did not realize you did not want one row per peptide and replicate.
If you just want one row per peptide, you should get rid of the following columns:
Normalized Area
File Name

-- Nick
 
lparsons responded:  2019-03-01
Nick

Thank you for the quick reply, that did indeed get me each peptide on a single row but now I have no intensities on the row at all. I might not have stated this clearly before but my goal is to have one row where I have all the intensities of that peptide on the row, with the rest of the information for that peptide (sequence, rt, mz, etc) on that same row.

thank you!
Lee
 
Nick Shulman responded:  2019-03-01
In that case, you should add back the "Normalized Area" column, and you should also click the checkbox at the bottom of the View Editor that says "Pivot Replicate Name".
This will give you one row per peptide, and replicate-specific columns will be repeated horizontally.
-- Nick