Problem in importing assay library

support
Problem in importing assay library ankit1517.niper  2019-02-07
 

Hi Skyline Team,

I am trying to import the spectral assay library which I built using the SpectraST on DDA data. It is in .tsv format, I am trying to follow your tutorial, but when I Click "the Create button to create a pseudo spectral library for the document to store the transition intensities" I got the message source spectrum not present. Although I kept the raw files as well as the iProphet output file in the same folder.
I also want to tell that my library has only Biognosys iRT standard petide detected, so I am using the iRT standard peptide's Assay library provided by you in the tutorial material. So can I do this or it is a wrong approach? If it is wrong could you please suggest the possible way out for this.
For your information, I used CiRT peptides for RT normalization of peptides in the spectral library during the library generation step.

Thanks.

 
 
Brendan MacLean responded:  2019-02-14

With a TSV assay library, you should be using File > Import > Assay Library. It sounds like you are trying to use a method to build a spectral library, but you already built a spectral library with SpectaST and went further by converting it to the TSV assay library. If you now use the File > Import > Assay Library function this should:

  1. Create a new spectral library with the intensities from your assay library TSV.
  2. Give you the opportunity to create an iRT library as part of your spectral library.
  3. Add all of the targets in your assay library to the current Skyline document.

If you just want a spectral library that Skyline can understand, you can forget the step to convert your SpectraST sptxt file to the tsv and just add the sptxt file as a library to Skyline directly without any build step (Peptide Settings - Libraries - Edit List > Add...) Then you can build your iRT library by going to Peptide Settings - Prediction, click the button with the calculator icon, Add, Choose the Biognosys standards and click Add > From Library selecting the SpectraST library.

But starting with the TSV, you may want to use File > Import > Assay Library.

Hope this helps. Thanks for posting to the Skyline support board.

--Brendan