pFind spectral library

support
pFind spectral library user4380  2018-12-28
 

Hello,

is it possible to import pFind search results into Skyline to obtain extracted ion chromatograms for identified peptides (MS1 XIC filtering)?
(the Open-pFind paper has just been published in Nature Biotechnology, volume 36, pages 1059–1061 (2018) ).

Kind regards,
Jure

 
 
Nick Shulman responded:  2018-12-28
This is the list of search results that Skyline knows how to read:
https://skyline.ms/wiki/home/software/BiblioSpec/page.view?name=BlibBuild

pFind is not on that list.

Skyline supports reading peptide identifications from a tab-delimited file with a list of the peptides and which MS2 scan they were detected in. The name that we gave to that format is "spectrum sequence list" (.ssl).
Here is a description of the .ssl format:
https://skyline.ms/wiki/home/software/BiblioSpec/page.view?name=BiblioSpec%20input%20and%20output%20file%20formats

If pFind is able to produce .pep.xml files, then it might be easy for us to add support for this. All search engines have different ways of storing the false discovery rate q-value in the .pep.xml file, so we always need to do a little bit of work to support new peptide search engines, even if they do produce .pep.xml files.

Can you tell us more about pFind and what its output files look like?
-- Nick
 
user4380 responded:  2018-12-28
Hi Nick,

I will upload the pFind result folder, which contains the spectra file.

I have a question with regard to the .ssl file (which includes: file, scan number, charge and sequence).
Is this .ssl file and Q Exactive Orbitrap .raw file all that is needed to generate XICs for peptides listed in the .ssl file? In other words, what is the MS1 filtering protocol when using an .ssl file?

Many thanks,

Jure
 
Nick Shulman responded:  2018-12-28
BiblioSpec does not know how to read .raw files, so I think you have to convert your .raw file to something like .mzML.

When you have your .ssl file and .mzML file next to each other, then, in Skyline, I believe you can do:
File > Import > Peptide Search
and Skyline will guide you through creating a spectral library from the .ssl file, and then extracting chromatograms from the .raw file.

I am not sure what your question about MS1 filtering protocol is.
It might be helpful if you took a look at the MS1 full scan filtering tutorial:
https://skyline.ms/wiki/home/software/Skyline/page.view?name=tutorial_ms1_filtering

You do not need peptide search results in order to extract chromatograms for peptides.
The steps to do MS1 extraction are:
1. Use the menu item Settings > Transition Settings to bring up the Transition Settings dialog.
On the "Filter" tab, change the "Ion Types" to "p" (for "precursor")
On the "Full Scan" tab, change the "MS1 filtering Isotope Peaks Included" to anything other than "None".
2. Use the menu item Edit > Insert > Peptides and enter the list of peptide sequences you want.
3. Use the menu item File > Import > Results to tell Skyline where to find your .raw file.

However, the advantage of creating the .ssl file is that you are telling Skyline what the retention time is of all of your peptides, and Skyline will do a much better job of choosing the correct peak if Skyline has that retention time information.
-- Nick
 
sunrui responded:  2018-12-30
Hi Jure
How about the pFind spectral library? I need to do the same thing. If you have any resolution, would you please to tell me. my email: sunrui@westlake.edu.cn

Many thanks,

--Rui