Number of transitions in the integration report file less than the number of transitions specified in the sky file

support
Number of transitions in the integration report file less than the number of transitions specified in the sky file pram1707  2018-11-18
 

I have 619 transitions in the .sky.xml file. When I use this to run my MS data, the resulting report has only 591 transitions. The rest are missing. Why is that?

 
 
Nick Shulman responded:  2018-11-19
I don't understand your question. Can you post a screenshot of what you are looking at?

It might be helpful if you send us your Skyline document.
In Skyline, you can use the menu item:
File > Share > (complete)
to create a .zip file containing your Skyline document and supporting files, including extracted chromatograms.

If that .zip file is less than 50MB, you can attach it to this support request. Otherwise, you can upload it here:
https://skyline.ms/files.url

-- Nick
 
Brendan MacLean responded:  2018-11-19
I expect it means that you did not have matching chromatograms for all of the transitions. What report are you using? There is a built-in report called "Transition Results" where transitions without results data are removed due to a filter in the "Filter" tab of the report editor. I just tried this myself by adding new transitions to a document where runs had already been reported, and the number of rows in the "Transition Results" report does not change.

If you like, you could post your report template to this support request for us to have a look at by doing the following:
File > Export > Report
Click Edit List
Select your report in the list
Click Share
Save a .skyr file and post that to this support request

I think this is the most likely explanation.

--Brendan

P.S. - Please post back to the support board instead of replying to this email message. A direct email reply will not reach everyone that monitors support.
 
pram1707 responded:  2018-11-19
Hello Brendan, We use command line interface for quantification. The formation for CLI script looks like this .
--in=${SKYLINE_TEMPLATE}
--import-file=${RAWMSDATA_MZML}
--report-name=${REPORT_NAME}
--import-transition-list=${TRANSITIONLIST_FILE}
--report-file=${REPORT_FILE}

We are not using the GUI interface at all. The report file we get after running this doesn't have all the transitions we specified in the transition list. We have 619 transitions and the report gives us only 591.
 
Brendan MacLean responded:  2018-11-19
Hi Prasanna,
That's great! The text you have pasted above appears to be parameterized. Despite the fact that you are using the command-line interface, it appears that you are using a named report template, which gets named by the line:

--report-name=${REPORT_NAME}

To supply the information I have requested, you would figure out what ends up actually getting used in place of ${REPORT_NAME}, then start up the Skyline GUI and share a .skyr file for that report as I have described.

I still think your best bet is that the report you are using applies some kind of filter and it is filtering out 38 of your transitions (619-591), but without more information, I won't be able to help more than that.

There are many ways to gain more information on the problem, though. You could, for instance, use Views > Transitions to export a report of just the transitions with no results information and no filtering and then open both your reports in Excel and use conditional formatting to form duplicates to find the transitions which are not duplicated. Those would be the missing 38. Then you could go have a look at those in the Skyline GUI and you would probably learn more.

When reports generated by command-line tools don't make perfect sense, it is time to have a closer look, and the Skyline GUI offers you a great tool for that investigation.

Hope this helps. If you can attach a .skyr file containing your report, or even use Settings > Document Settings > Reports to check the report, save you file and then post it to the location Nick suggests:

https://skyline.ms/files.url

And we will have a closer look and probably learn a lot we can share with you.

--Brendan
 
pram1707 responded:  2018-11-20
Hi Brendan,

I ran those 28 transitions separately through skyline. It works perfectly. But not when I throw it in with the other 591. I suspect there might be some overlap. That's my best guess. But let me also use the GUI and check if the same problem exists. I will ask my colleagues and see what I can share.

Thanks,
Prasanna
 
Brendan MacLean responded:  2018-11-20
Please do involve the GUI in your attempt to understand. I expect you will get there much quicker when you can see all the details of what is going on, i.e. look at the targets and the chromatograms for the 28 transitions now that you have identified them.

You could start by just making sure you save your results to a Skyline document on disk and then open that in Skyline and have a look at the 28 transitions, and use View > Document Grid, then choose your report name from the Views menu on the Document Grid to look at the report, and then Views > Edit View to look at the view/report definition and check for any filters in the Filter tab.

Good luck. Let us know if you can share any more information or you figure out what is going on.
 
pram1707 responded:  2018-11-20
I will work with the GUI. I can share the SRM settings. Let me know if something stands out.

<?xml version="1.0" encoding="utf-8"?>
<srm_settings format_version="3.73" software_version="Skyline (64-bit) 4.1.0.11796">
  <settings_summary name="Default">
    <peptide_settings>
      <enzyme name="Trypsin" cut="KR" no_cut="P" sense="C" />
      <digest_settings max_missed_cleavages="0" />
      <peptide_prediction use_measured_rts="true" measured_rt_window="2" use_spectral_library_drift_times="false" spectral_library_drift_times_peak_width_calc_type="resolving_power" spectral_library_drift_times_resolving_power="0" spectral_library_drift_times_width_at_dt_zero="0" spectral_library_drift_times_width_at_dt_max="0" />
      <peptide_filter start="25" min_length="8" max_length="25" auto_select="true">
        <peptide_exclusions />
      </peptide_filter>
      <peptide_libraries pick="library" />
      <peptide_modifications max_variable_mods="3" max_neutral_losses="1">
        <static_modifications>
          <static_modification name="Carbamidomethyl (C)" aminoacid="C" formula="H3C2NO" unimod_id="4" short_name="CAM" />
        </static_modifications>
        <heavy_modifications />
      </peptide_modifications>
    </peptide_settings>
    <transition_settings>
      <transition_prediction precursor_mass_type="Monoisotopic" fragment_mass_type="Monoisotopic" optimize_by="None">
        <predict_collision_energy name="Agilent QQQ" step_size="3" step_count="3">
          <regression_ce charge="2" slope="0.031" intercept="1" />
          <regression_ce charge="3" slope="0.036" intercept="-4.8" />
        </predict_collision_energy>
      </transition_prediction>
      <transition_filter precursor_charges="2" product_charges="1" precursor_adducts="[M+H]" product_adducts="[M+]" fragment_types="y" small_molecule_fragment_types="f,p" fragment_range_first="m/z &gt; precursor" fragment_range_last="3 ions" precursor_mz_window="0" auto_select="true">
        <measured_ion name="N-terminal to Proline" cut="P" sense="N" min_length="3" />
      </transition_filter>
      <transition_libraries ion_match_tolerance="0.5" min_ion_count="0" ion_count="1" pick_from="none" />
      <transition_integration />
      <transition_instrument min_mz="50" max_mz="2200" mz_match_tolerance="0.2" />
    </transition_settings>
    <data_settings document_guid="34506be5-bf19-4b5e-83ab-72f8c7dc3f3d" />
  </settings_summary>
 
pram1707 responded:  2018-11-20
Hello Brendan,

I just uploaded the skyr file. Can you take a look and tell me if you see the problem. Thank you so much for your help.

Best,
Prasanna
 
Brendan MacLean responded:  2018-11-20
The .skyr file you uploaded contains 5 reports, which look like the Skyline defaults for these report names:

1. Peak Boundaries
2. Peptide Quantification
3. Peptide RT Results
4. Small Molecule Transition List
5. Transition Results

The three reports (1, 3, 5) that include information about results files all have a filter for transitions with no results:

    <filter column="Results!*.Value" opname="isnotnullorblank" />

So, if you used any of these, then getting a number of rows that was fewer than the number of transitions you targeted would be perfectly explained by what I have already proposed, that some of your transitions do not have matching chromatograms in your data, which could be caused by a number of reasons. Your settings don't show any full-scan chromatogram extraction settings. So, it would seem you are working with selected ion chromatograms from a triple-quadrupole instrument. I expect if you look at your 28 transitions in Skyline, you will find that they do not have chromatogram information (indicated by lacking a green, orange or red dot to the left of the transition text and icon).

What is the name of the report you are actually using? And am I correct that this is triple quadrupole data?
 
pram1707 responded:  2018-11-20
Yes we are using selected ion chromatograms from a triple-quadrupole instrument. How do I change the filter settings? We are using 'Transition Results' for our --report-name. I f I want to change the filter how do I do it?
 
pram1707 responded:  2018-11-20
I am a little new to skyline. I am learning, while I am troubleshooting issues. Thank you for your patience and prompt response.
 
Brendan MacLean responded:  2018-11-20

In Skyline, do the following:

  • View > Document Grid
  • On the Document Grid - Views menu, click the name of the view you use when running the command-line
  • On the Document Grid - Views menu, click Edit View
  • Click the Filter tab - which will show a single filter row selected "Transition Result > Is Not Blank"
  • Click the black X button to the right of the selected filter row
  • Click the OK button in the "Customize View" form.

That should give you extra rows for your transitions which do not have results, but they will have #N/A in all peak statistics columns like Area, Background and Peak Rank.

Hope this helps.

 
pram1707 responded:  2018-11-20

Thank you so much. I really appreciate your help. I made the changes. Will keep you posted on the results.

 
pram1707 responded:  2018-11-20

Hi Brendan, The problem got fixed. Thanks for the help and guidance. I really appreciate it.

 
Brendan MacLean responded:  2018-11-20

Okay, but do you understand why you had 28 transitions with no chromatograms?

 
pram1707 responded:  2018-11-20

I don't really understand. I ran those 28 separately. And the report says that the peak was found for most of the transitions. But it is #n/a when we run the same with all 619 transitions. I have to look into it further. If the peak was not there, both reports should have the same results.