Cannot retrieve application. Authentication error.

support
Cannot retrieve application. Authentication error. aisling donnelly 3  2018-11-16
 

Hi,

I had the previous version of Skyline downloaded on to my computer and tried to download the updated version (64-bit 4.2), however it does not seem to be working. I tried to delete the previous version I had of it and re-download the new one but it still won't work. I also tried the unplugged version but the same error came up that said "Cannot retrieve application. Authentication error." It seems to download fine but once it's finished downloading it won't open.

I have attached an image of the error that comes up and the details it shows. I now can't get any version of Skyline on to my computer.

Thanks for your help,
Aisling

 
 
Brendan MacLean responded:  2018-11-16

Hi Aisling,
I would first try moving the location of your "Skyline-64_4_2_0_18305" to your "Documents" folder. It appears to be currently located on your Desktop. Sometimes organizations will lock down desktop permissions. For this reason, I always have people but things in "Documents" when I am out teaching Skyline.

Also, could you maybe try the normal network installer and send the error log for it? This version will automatically ask to update when we release the first Skyline 4.2 patch with some potentially important fixes. So, I would like to understand the error in that context if possible.

Thanks for sending the log file.

--Brendan

 
aisling donnelly 3 responded:  2018-11-17

Hi Brendan,

I have moved the location of "Skyline-64_4_2_0_18305" to "Documents" and I still have the same error unfortunately. I deleted this folder and re-downloaded it again in to "Documents" just to see would this fix it, but again have the same error.

I have attached the error log for the normal network installer.

Thank you,
Aisling

 
Brendan MacLean responded:  2018-11-17

You have attached a screenshot of the error message. I would like to see the text you see when you click the Details button on that message window.

Also, if you still get exactly the same log for the unplugged installer, can you find the file MSMSDBCntl.dll inside the installation folder? The log has the exact path. When you right click on it and click Properties do you see anything unusual? Is it marked read-only or anything else unexpected?

Finally, can you reproduce this issue on any other computer around you? Your colleagues in the same building? Or anywhere, Or is it specific to this one computer. This is the first I have seen this problem.

Thanks for your help in narrowing in on the cause of the issue.

—Brendan

 
aisling donnelly 3 responded:  2018-11-17

Hi Brendan,

I actually got it working. While I was looking for the MSMSDBCntl.dll file I came across Skyline listed as an application within that folder. I must have had it the whole time but had been trying to use the setup application in the main folder to launch Skyline.

Thanks for all of your help.

Aisling

 
Brendan MacLean responded:  2018-11-18

Hi Aisling,
That is certainly one way of running Skyline. It is true that you can run Skyline from where it sits once you extract all the files in the ZIP file of an unplugged installer. This isn't a complete installation and won't get you the file association that allows you to double-click on a .sky file and have it open automatically in Skyline.

It would be great if we could continue to try to understand why your setup.exe is failing to fully install Skyline, but also nice that you have a working solution you are happy with, as that takes some of the pressure off.

If you could post the actual logged details of your web installation and report whether you see any special properties on MSMSDBCntl.dll that might still be informative.

Thanks for the latest update.

--Brendan