Exclude Oxidized Methionine not working

support
Exclude Oxidized Methionine not working jmeyer  2018-11-14
 

Dear Skyline Team,

I'm trying to exclude peptides with oxidized Methionine from an import of the pan-human transition list from swathatlas, and the usual regex exlusion isn't working (see attached):

[M][+

I have set "pick peptides matching" to "Library and Filter", and I tried Edit>refine>advanced>Auto-select all peptides, precursors, transitions.

Am I missing something or is there a bug?

I put the complete share here:
https://drive.google.com/file/d/1eMpaL9trFcUEJrTTcbJgBIpMPr-XOD0D/view?usp=sharing

Thanks in advance,
Jesse

 
 
Brendan MacLean responded:  2018-11-14

This is probably an oversight or at least an area we need to revisit and think through, but the current implementation does not apply those peptide filters to what Skyline considers "peptide lists", that is lists of peptides supplied by the user with no relationship to a protein sequence. We leave it up to the user to make sure their peptide lists contain the peptides they are interested in and Skyline accepts them even if they do not mean many settings criteria. For example, they need not be tryptically cleaved.

If you want to get rid of those MetOx peptides, your best route may be to use View > Document Grid. Choose Views > Peptides on the Document Grid menu. Click the Peptide Modified Sequence column header and click Filter. Set a Contains filter on M[.

This should limit the Document Grid to just the 5641 peptides in your document with MetOx. Press Ctrl-A to select them all and then click the red X button in the Document Grid toolbar. You will be asked if you are sure you want to delete all 5641 and if you click OK. They will all be removed from your document (after a few seconds wait).

I just achieved this successfully. Hope it works for you. Thanks for the clear post to the support board with the screenshot and shared file.

--Brendan