The document format version 4.2 is newer than the version 3.73 supported by Skyline (64-bit) .

support
The document format version 4.2 is newer than the version 3.73 supported by Skyline (64-bit) . voellmy  2018-11-12
 

Hi Skyline team,

Since upgrading to the latest Skyline version (I now have 4.2.1.18305), I am having trouble using SkylineRunner. I get the following error:
"The document format version 4.2 is newer than the version 3.73 supported by Skyline (64-bit) .". What can I do to resolve this ? I've tried saving an older (and functioning) Skyline document with the newest version and this reproduces the error, so I'm fairly certain the version is the issue.

Thanks for your help,
Franziska

 
 
Brendan MacLean responded:  2018-11-12

Hi Fanziska,
It looks like you are running Skyline from C:\Program Files\Skyline\SkylineCmd.exe

This is where the administrator installer puts Skyline and based on this message, you must still have Skyline 4.1 in this location (which because of a mistake during its release supports the document format version 3.73). The message is also consistent with your assertion that you are using 4.2.1.18305 to create the Skyline document you are trying to open (since 4.2.x will produce a 4.2 format document).

To fix this issue, you should use the latest administrator installer to update the Skyline version under "Program Files".

https://skyline.ms/skyline-admin64.url

Thanks for your clear description and the log file.

--Brendan

 
voellmy responded:  2018-11-12

Hi Brendan,

Thanks for the quick help, that solved my issue.