The document format version 4.2 is newer than the version 3.73 supported by Skyline (64-bit) .

support
The document format version 4.2 is newer than the version 3.73 supported by Skyline (64-bit) . voellmy  2018-11-12
 

Hi Skyline team,

Since upgrading to the latest Skyline version (I now have 4.2.1.18305), I am having trouble using SkylineRunner. I get the following error:
"The document format version 4.2 is newer than the version 3.73 supported by Skyline (64-bit) .". What can I do to resolve this ? I've tried saving an older (and functioning) Skyline document with the newest version and this reproduces the error, so I'm fairly certain the version is the issue.

Thanks for your help,
Franziska

 
 
Brendan MacLean responded:  2018-11-12

Hi Fanziska,
It looks like you are running Skyline from C:\Program Files\Skyline\SkylineCmd.exe

This is where the administrator installer puts Skyline and based on this message, you must still have Skyline 4.1 in this location (which because of a mistake during its release supports the document format version 3.73). The message is also consistent with your assertion that you are using 4.2.1.18305 to create the Skyline document you are trying to open (since 4.2.x will produce a 4.2 format document).

To fix this issue, you should use the latest administrator installer to update the Skyline version under "Program Files".

https://skyline.ms/skyline-admin64.url

Thanks for your clear description and the log file.

--Brendan

 
voellmy responded:  2018-11-12

Hi Brendan,

Thanks for the quick help, that solved my issue.

 
voellmy responded:  2019-01-11

Hi,
I'm again having the same problem as earlier in this thread, this time with the latest upgrade: "Failure opening ... . The document format version 4.21 is newer than the version 4.2 supported by Skyline (64-bit) 4.2.0.19009." The solution installing the administrator version doesn't seem to solve the issue this time however.

Thanks for your help,
Franziska

 
Nick Shulman responded:  2019-01-11
You need to use Skyline-Daily to open that file.
You can install Skyline-Daily from here:
https://skyline.ms/project/home/software/Skyline/daily/begin.view?

We do not yet have a Skyline administrator installer for the most recent Skyline-Daily. If you need one of those, I could build it today.
-- Nick
 
voellmy responded:  2019-01-11
Thanks, I'll try with Skyline daily first.

-Franziska
 
voellmy responded:  2019-01-14
Hi,
I installed Skyline-Daily, but unfortunately this opened up another issue on my side.
I'm able to open the file using Skyline-Daily GUI, however when I now use SkylineDailyRunner (or also the older SkylineRunner) I always get the following error :

Error: Failed importing the results file 20181025_OR12_Ag2_3522075_SA_PE_M51-Y_1,8ul.raw.
[2019-01-14 15:57:57]    Message: System.IO.FileNotFoundException: Could not find file 'D:\forD\test\data\Library_centroid.skyd'.
File name: 'D:\forD\test_1fileD\data\Library_centroid.skyd'
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at pwiz.Skyline.Util.FileStreamManager.CreateStream(String path, FileMode mode, Boolean buffered) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Util\UtilIO.cs:line 584
   at pwiz.Skyline.Util.PooledFileStream.Connect() in C:\proj\pwiz_x64\pwiz_tools\Skyline\Util\UtilIO.cs:line 419
   at pwiz.Skyline.Util.ConnectionPool.GetConnection(Identity id, Func`1 connect) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Util\UtilIO.cs:line 227
   at pwiz.Skyline.Util.ConnectionId`1.get_Connection() in C:\proj\pwiz_x64\pwiz_tools\Skyline\Util\UtilIO.cs:line 332
   at pwiz.Skyline.Util.PooledFileStream.get_Stream() in C:\proj\pwiz_x64\pwiz_tools\Skyline\Util\UtilIO.cs:line 472
   at pwiz.Skyline.Model.Results.ChromatogramCache.Load(String cachePath, IProgressStatus status, ILoadMonitor loader, Boolean assumeNegativeChargeInPreV11Caches) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromatogramCache.cs:line 562
   at pwiz.Skyline.Model.Results.ChromatogramCache.Build(SrmDocument document, String documentFilePath, ChromatogramCache cacheRecalc, String cachePath, MsDataFileUri msDataFileUri, IProgressStatus status, ILoadMonitor loader, Action`2 complete) in C:\proj\pwiz_x64\pwiz_tools\Skyline\Model\Results\ChromatogramCache.cs:line 609



I've tested with other raw files, libraries as well as with SkylineRunner and always get the same type of error. This is the line I'm running:
"C:\Program Files\Skyline\SkylineDailyRunner.exe" --timestamp --dir="D:\forD" --in="Library_centroid.sky" --out="test_1fileD\data\Library_centroid.sky" --full-scan-rt-filter-tolerance=5

Is there something I should have changed when installing Skyline-Daily?

Thanks for your help,
Franziska
 
Nick Shulman responded:  2019-01-14
I do not know what could be causing that error.
Skyline is trying to read the file:
D:\forDonna\test_1fileDonna\data\Library_centroid.skyd

The .skyd file contains the chromatograms that have been extracted from the raw file. I am not sure why Skyline is not able to find the file.

The command line that you were running when this error happened was:
"C:\Program Files\Skyline\SkylineDailyRunner.exe" --timestamp --dir="D:\forDonna" --in="test_1fileDonna\data\Library_centroid.sky" --import-process-count=3 --import-all="test_1fileDonna" --reintegrate-model-name="data" --reintegrate-create-model --reintegrate-overwrite-peaks --save --report-add="D:\forDonna\lfqbench\SWATHbenchmark_report.skyr" --report-conflict-resolution=overwrite --report-name=SWATHbenchmark --report-file="test_1fileDonna\data\SWATHbenchmark.csv" --report-invariant

Skyline extracted chromatograms from:
D:\forDonna\test_1fileDonna\20181025_OR12_Ag2_3522075_SA_PE_M51-Y_1,8ul.raw

I am not sure whether Skyline successfully finished extracting chromatograms from that .raw file. It might be that there was a bug and Skyline tried reading from the .skyd file before Skyline was actually finished creating that file.

One thing that you could try doing is removing that "--import-process-count=3" part of the command line. That option tells Skyline to launch extra instances of itself in order to do the work of extracting chromatograms. I could imagine that if there is a timing issue causing a bug, the problem might
be fixed if you do not specify that option.

If you want to go back to using Skyline version 4.2, you can use Skyline-Daily to save your document in the previous version format.
In Skyline, you can use the menu item:
File > Share
and on the dialog that comes up, there is an option to save in the format of previous versions of Skyline.

Maybe someone else has a better idea what is going wrong for you.
-- Nick