Specific-modified peptides don't appear

support
Specific-modified peptides don't appear ncampoloh  2018-11-07
 

Hi!

I am writing to ask you help about some trouble I'm having in seeing in Skyline some specific modified peptides; it's probably something easy to solve, but after trying many things, I still couldn't get to solve it.
I have MS/MS data of a digested pure protein, acquired by a universal method in an Orbitrap fusion. I have a control condition and two conditions were the enzyme was treated with an oxidizing agent. My intention is to detect the oxidative PTMs that some amino acids undergo after treatment, and have some approach to its levels doing some relative quantification with Skyline (comparing the peak areas of the modified peptides with respect to the unmodified ones).
I used MaxQuant to process each raw file for doing the peptide search, so I imported into Skyline the msms.txt that MaxQuant generated. For the treated conditions, I found the following modifications in many residues: methionine oxidation, tyrosine oxidation, tyrosine nitration and tryptophan nitration. The problem I have is, that when I do all the steps for analyzing the data in Skyline and import the peptide search, the raw file and the fasta sequence of the protein, I don't see all of the peptide variants that were originally detected. In particular, I see peptides modified by methionine and tyrosine oxidation, but not the ones that contained nitrated tyrosine or tryptophan. I included all of these modifications on the peptide settings (I added manually and checked that the mass values of each were the same that MaxQuant used), so that shouldn't be the problem. I tried both doing MS1 filtering and DIA approaches but in none of the cases those peptides appear. I think that the modifications were properly considered, given that when I remove the filtered peptide sequences by clicking the identified protein, all of the peptide possibilites appear, but with no data assigned to them (as if they were not detected in the peptide search).
I've tried including the ambigous mathces when importing the peptide search, including all the matching scans in the retention time filtering, varying the precursor charges, etc. But those peptides that were found won't appear, and it is a shame because the nitrated variants are the ones in which I'm more interested in comparing.
I would really appreciate any help and aid you can give me, because I couldn't get a solution yet and I really want to do some good use of Skyline for this type of analysis! I hope my doubt has been clearly explained.
Many thanks!

Nicolás

 
 
Nick Shulman responded:  2018-11-07
Can you send us your Skyline document and your MaxQuant search results? For the MaxQuant results, we need the msms.txt, and maybe the mqpar.xml and modifications.xml.

In Skyline, you can use the menu item:
File > Share > (complete)
to create a .zip file containing your Skyline document and supporting files including the spectral library that you created from your MaxQuant results.

If that .zip file and the other files are less than 50MB then you can attach them to this support request. Otherwise, you can upload them here:
https://skyline.ms/files.url

Let us know an example of a peptide with modifications that seems to be missing from your Skyline document and I will try to figure out what is going wrong.
-- Nick
 
ncampoloh responded:  2018-11-08
Dear Nick:

Many thanks for your answer. I attach you the files you mentioned here.
I tried doing everything again but in a different way and I think that maybe I have now an idea of what could be the problem. Until today, everytime I loaded the peptide search, I had previously setted the modifications on Settings/Peptide Settings/Modifications, including there all the structural modifications of interest (the ones found in the MaxQuant search) as loaded from Unimod. Here, nitration modifications appear individually as Nitro(Y) and Nitro(W).
Then, after loading the raw file and the fasta file, the peptides containing oxidized tyrosine/methionine were found and shown, but not the nitrated ones. Today, I did everything the same, but without previously selecting any amino acid modification on Settings/Peptide Settings/Modifications. So, when I loaded the peptide search, a window appeared that told me that certain PTMs were detected on the document and suggested me to select them (see image attached, but it is the same as happens in the MS1 filtering tutorial). There, all of the modifications used in MaxQuant appeared, except for nitration of tyrosine and tryptophan. So, it appears that Skyline is having trouble in recognizing the nitration PTM that is used in MaxQuant, although the mass shift is exactly the same. I think that I may have an idea on why that is happening, and I will try to fix that. In Unimod, the nitration modifications appear as individual and with this name: "Nitro (Y)" and "Nitro (W)". In MaxQuant, I manually added the nitration modification as a single one that can apply both to tyrosine and tryptophan, which has this name: "Nitraion (Y, W)". Is it possible that this difference (especially the fact that it is one modification for both amino acids) is making that this modification is not being recognized in Skyline?
I will try to do the MaxQuant searchs again, splitting the nitration modification into two separate ones, and then import that peptide search to see if it is recognized now. I attach the files anyway, but I hope I can solve the problem this way and not have to bother you with this!
Many thanks again for your attention!
Kind regards!
Nicolás
 
Nick Shulman responded:  2018-11-08
It looks like you're using an older version of Skyline. When you go to "View > Spectral Libraries", that "Add Modifications" dialog is supposed to have a lot more digits of precision.

Skyline thinks that the Nitro modification has a mass of 44.985 and the formula is "NO2 - H".
The modifications on your Y's and W's have a mass of 15.9949, which is why Skyline suggests that those modifications might be oxidation.
I don't see any modifications in your search results that have a mass like 44.985. Are you sure you meant the Nitro modification? What's the chemical formula of the modification you're thinking of?
Also, do you know what the modification with the mass of 58.005479 is supposed to be? That's the one that Skyline suggests is "Carboxymethyl (N-term)"

It is best if you tell Skyline about all of your modifications before you bring up the "View > Spectral Libraries" dialog. Skyline often guesses wrong when it offers to add modifications to your document.
 
ncampoloh responded:  2018-11-08
Hi Nick!

I've done what I described in my last message in MaxQuant (changing the nitration modifications from one single into two) but the problem is still there. In MaxQuant, the nitrated variants are detected, I can see the peptide sequences, the spectrum, retention times, intensity, and all that info that comes in the output of MaxQuant. But in Skyline, those modifications are not recognized.
Perhaps the fact that I have a Skyline version with less digits of precision is causing that it doesn't recognize the nitro modification, but it is strange that the same doesn't happen with the oxidation ones. I'm totally sure about the presence of the nitro modification in several peptides; I attach you some pictures where I can see such peptides in MaxQuant. Also, you can check the mass of such peptides by opening in excel the peptide search file (msms.txt). The nitro modification that I have in MaxQuant has this mass: 44.9850782173. It's chemical formula is the one you mentioned, the same Skyline considers (NO2 -H).
If it is a problem of digits, maybe I can check by downloading a new version of Skyline and see if that solves. I can also try to do the peptide search in another software, to see if the problem can maybe solved by this. I will keep trying to see if these peptides show up!
I have no idea of why Skyline is suggesting me the Carboxymethyl (N-term), I haven't used that modification at the MaxQuant search.
Thanks for your aid!

Nicolás
 
Nick Shulman responded:  2018-11-08
BiblioSpec (which is what Skyline uses to build spectral libraries) does not know what the "ni" and "ox" modifications are.
It is unfortunate that Skyline does not give you any sort of warning about this. The only way to see this warning would be to run BiblioSpec from the commandline with the "-v warn" flag.

Do you maybe have a modifications.xml file which has the definition for what these modifications are? Skyline has its own copy of the modifications.xml file that comes with MaxQuant, but it does not look like the Nitration modification is in there, so I suspect you have your own copy of that file.

I believe if you put your own modifications.xml file (or maybe "modification.xml" without the "s") in the same folder as your msms.txt, things will work right.
-- Nick
 
ncampoloh responded:  2018-11-08
You got it Nick!
Problem solved! I made sure that the modifications.xml of MaxQuant contained the modifications I included manually (initially, they were on another xml, but there was an option to put them in the same), and then I just copied and pasted that file in the folder where I had the msms file. Now, the BiblioSpec contains the nitrated peptides and I can see really nice peaks corresponding to the nitrated peptides!
Thanks a lot Nick, you really helped me a lot with this!
I really appreciate the time you spent in helping me, hope now I can continue well with all and not bother you again!
Thanks again for everything Nick!
Best regards!

Nicolás