wiff2 file support

support
wiff2 file support sandberg  2018-11-06
 

Is it possible to import and process the new wiff2-file format from AB Sciex with version 4.2? The file extension does not appear in the list of importable MS formats and the files do not show up in the import window. Thx.

 
 
Brendan MacLean responded:  2018-11-06

Sigh. It looks like we didn't quite get WIFF2 support (which was very last-minute) surfaced to Skyline. The work to expose it is relatively minimal, though, and I promise it will be a part of the first Skyline 4.2 patch release.

 
sandberg responded:  2018-11-14

Ok. Do you have any estimate of when this will happen?

 
Brendan MacLean responded:  2018-11-14

The fix will be in the next releases of both Skyline-daily and Skyline. It will be released first in Skyline-daily, probably by next Monday. I am teaching at the EMBL Targeted Proteomics course in Barcelona, so probably too busy to make a release before Saturday when I return to Seattle.

For an official Skyline release you likely will need to wait at least a couple more weeks, as we work to assemble multiple fixes we would like to release in the first patch to Skyline 4.2.

 
sandberg responded:  2018-11-14

Ok, great! Thank you.

 
lund responded:  2018-11-27

Hi!
Is there any news regarding wiff2 support?
Rikke

 
Brendan MacLean responded:  2018-11-27

It should be in the latest Skyline-daily release 4.2.1.18329 announced Sunday night.

https://skyline.ms/announcements/home/software/Skyline/daily/thread.view?rowId=38238

Please test this release and let us know if the fix was successful. Once we here back on some of the fixes we will release our first patch to Skyline 4.2 which should contain this WIFF2 fix.

Thanks for checking.

 
lund responded:  2018-11-28

Hi Brendan
We have tested it but we were not able to get it to work.
We tried in two ways:

  1. Import DDA Peptide search, but were not able to import the wiff2 in the "Import Pepetide Search" step (skyline_wiff2_1). Wiff2 is not on the list and selecting a wiff2-file does not lead to any importing.
  2. Importing the file from file->import->results, this lead us a bit further (skyline_wiff2_2), but still no imported files.
    I hope this helps you to figure out how to fix it :-)
    Rikke
 
Brendan MacLean responded:  2018-11-28

Hi Rikke,
In the #1 case it looks like you somehow performed your Mascot search in a way that dropped the spectrum source file name, which is why you see it showing you the .dat name, and that name "18247_2_2000ppm.dat" does not match the basename of any of your .wiff2 files. The closest being "18247_2_2000ppm_20ug.wiff2". If you change the name of either the .dat or the .wiff2 to match, or you fix your search pipeline to store source file names in your Mascot searches (see https://skyline.ms/wiki/home/software/Skyline/page.view?name=mascot_missing_rt).

The type "ABSciex WIFF" should include both .wiff and .wiff2 now. Though, that should probably changed to "Sciex WIFF & WIFF2". Thanks for pointing that out. But also "Any spectra format" is clearly working in the image you sent, since I can see all your .wiff2 files. The problem is that none of them have a base name matching your .dat file, which is what Skyline is asking you to find.

As for the error in #2, we will look into that, if you can post an example file to:

https://skyline.ms/files.url

Thanks for testing our attempts to get WIFF2 support working for Skyline users.

--Brendan

 
Brendan MacLean responded:  2018-11-28

We do really need files to reproduce this. Ideally you would post both a Skyline document (File > Share - Complete to create a ZIP file) and a WIFF2 with data for your targets, but even having just the WIFF2 would help.

Again, just upload to:

http://skyline.ms/files.url

 
lund responded:  2018-11-29

Hi Brendan
Thanks a lot for looking into it so fast :-)
I have uploaded a zip file "for skyline" description: "files for wiff2 issue".
It should contain a complete wiff2 file, a skyline file, a mgf file generated by Proteowizard and a fasta-database.
Please let me know if you need more files or information
Rikke

 
matt.chambers42 responded:  2018-11-29

OK. It only happens with the acceptZeroLengthSpectra mode that Skyline uses (but msconvert doesn't by default). It's a Sciex API bug, but we should be able to work around it. Thanks for the test file.

 
lund responded:  2018-12-03

Yeah! Have downloaded the new skyline daily. It also works with my original file!
Thanks :-)