Error loading wiff files

support

 This is a request about another page. view page
Error loading wiff files Ryan Hill  2017-06-27
 
Hello,

  After updating to the new version, I seem to have issues monitoring wiff files that are currently in progress. I have a weeks worth of samples and normally monitor tech reps in skyline throughout the day. However, when trying to open the batch file that still had samples being added to it, I now get an error:

"System.Reflection.TargetInvocationException: [read_file_header()] Unable to open file F:\Analyst Data\Projects\Hanen lab\201704\Data\201706 Humacyte.wiff (invalid permission or file locked) ---> System.Exception: [read_file_header()] Unable to open file F:\Analyst Data\Projects\Hanen lab\201704\Data\201706 Humacyte.wiff (invalid permission or file locked)
   at pwiz.CLI.msdata.ReaderList.readIds(String filename)
   at pwiz.Skyline.FileUI.ImportResultsDlg.<>c__DisplayClass8.<GetWiffSubPaths>b__4() in c:\proj\skyline_3_7_x64\pwiz_tools\Skyline\FileUI\ImportResultsDlg.cs:line 402
   at pwiz.Skyline.Controls.LongWaitDlg.RunWork(Action`1 performWork) in c:\proj\skyline_3_7_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 228
   --- End of inner exception stack trace ---
   at pwiz.Skyline.Util.Helpers.WrapAndThrowException(Exception x) in c:\proj\skyline_3_7_x64\pwiz_tools\Skyline\Util\Util.cs:line 1935
   at pwiz.Skyline.Controls.LongWaitDlg.PerformWork(Control parent, Int32 delayMillis, Action`1 performWork) in c:\proj\skyline_3_7_x64\pwiz_tools\Skyline\Controls\LongWaitDlg.cs:line 179
   at pwiz.Skyline.FileUI.ImportResultsDlg.GetWiffSubPaths(String filePath) in c:\proj\skyline_3_7_x64\pwiz_tools\Skyline\FileUI\ImportResultsDlg.cs:line 402"

I can get around this by using the sciex scripts to extact subset files. However, even when loading these extracted samples, there seem to be some bugs that don't go away until I either transfer everything to a different computer or restart the system.

If I stop the acquisition, the samples seem to load fine and are not corrupt despite the warning. I'm not sure if this was in line with Enrique's problem, but just thought I'd bring it to your attention.

Thanks!
Ryan
 
 
Nick Shulman responded:  2017-06-27
I would not expect Skyline to be able to read from a .wiff file while the mass spectrometer is still writing to it.

The Panorama AutoQC tool works around this by waiting a certain number of minutes (default 75) after the file was written before asking Skyline to start processing it.

Are you saying that this used to work better than it does now?
 
Ryan Hill responded:  2017-06-27
My apologies, I worded that wrong. I meant to say completed wiff files that are in the same data file. As in when you load all individual files for a project under the same data file name. Opening the data file in skyline generally gives you the list of completed wiff files within that batch. This error comes up when trying to open the data file that contains the wiffs.
 
becker78 responded:  2017-06-29
After installing the most recent Skyline release I am also having errors like Ryan describes.
 
Brendan MacLean responded:  2017-06-29
Can I ask you to quickly rollback your installation and check that this fixes the problem? You can simply go through steps to uninstall, and when asked choose to rollback instead of uninstalling completely.

Are you also saying you see this on completed multi-sample WIFF files? Is that what you are saying Ryan? Wiff files that contain multiple samples? I have to admit I am a little confused by the description of "This error comes up when trying to open the data file that contains the wiffs." To me a "wiff" is a file, i.e. filename.wiff. That file may contain multiple "runs" or "samples", but when you talk about a "data file" containing "wiffs" you start to lose me. If this is not interchangeable with a "wiff file" containing "runs/samples", please clarify.

Our tests definitely import multi-sample wiff files. So, we will probably need to get example files from one or both of you, which you can provide through:

http://skyline.ms/files.url

We would need a Skyline document (use File > Share to create a ZIP file and upload that) and a WIFF file that consistently reproduces the problem (ZIP that also and be sure to include .wiff and .wiff.scan also if appropriate).

Thanks for the reports.

--Brendan
 
becker78 responded:  2017-06-30
Hi Brendan and team,

I think the language confusion is that Analyst calls the file (.wiff and .wiff.scan) the "Data File" in it's menus and batch building interface.

I see the error both in daily and in the current release version.

The error only occurs when data is actively collecting.
We typically will submit a batch with multiple injections saving into the same .wiff/.wiff.scan file
Previously once an injection was complete it was possible to go and pull that injection into skyline allowing us to double check all was proceeding well with our runs. Injections that were still in process did not appear in the menu to select a sample for import.

Now, if we try and import a completed sample we get errors. Once the run is complete and no longer writing to the wiff/wiff.scan file then we can import data as normal, no problem. I'm attaching the errors for Daily. Later once that's complete I'll get screenshots of the errors with my run that I analyze with the release version. Then I'll roll back the version and see what happens.

Since the error only occurs when data is actively collecting I'm not certain how to show you the problem in action.
 
Ryan Hill responded:  2017-06-30
Thank you for the clarity Becker. I have a separate set starting this afternoon and will reproduce the problem, then rollback and see if it persists. Will be in touch soon as well.

Thanks again for all the help.

Cheers,

Ryan
 
becker78 responded:  2017-06-30
Hi Brendan,

I'll email you the screenshots of the errors that occurred when I attempted to import samples from release version 3.7. After confirming that error, I went ahead with the roll back of my installation to version 3.6. After doing this I am once again able to import an injection that is complete while data is continuing to collect on other injections to the same .wiff/.wiff.scan file.

Thanks for looking into this issue. I'd be pleased to hear if there's a resolution going forwards.

Regards,
Jess
 
Brendan MacLean responded:  2017-06-30
Thanks for the detail. We did take a reader DLL update from SCIEX within the last year. Here is what David Cox, from SCIEX, has to say about this:

"The development team is getting a new reader ready for me. It should have a simpler interface and fewer dlls. I’ll confirm with them that it opens files in read mode and not read/write mode. That should prevent any lock error."

So, it looks like this might not take long to get an update for. Otherwise, if you want to be able to do this sooner, you will need to revert to an earlier version that used the older DLLs. I think that would have to be 3.5, though. Please post to this thread, if you figure out what the last version was that worked for you.

Thanks again for reporting your issues and taking the time to work with us on getting them fixed.

--Brendan
 
matt.chambers42 responded:  2017-06-30
One potential way to make a reproducible file is to kill the acquisition process while it's working. Obviously you don't want to do that on real data. But:
1. Start a 1 minute acquisition of a buffer/blank-only sample and let it finish normally.
2. Start a 10 minute acquisition of a buffer/blank-only sample and while it's running, kill (End Process) the instrument acquisition software (I can't tell you what process needs to be killed though), or turn off the computer.

The result should be a file with one complete sample and one incomplete sample. This is not exactly the same as trying to open a complete sample while the acquisition software is writing another sample to the same WIFF, but it might trigger the same bug. Only Sciex could create a proper repro of this because they're the only ones that have access to the WIFF writing API.
 
becker78 responded:  2017-06-30
The Skyline 3.6 full release version still works for me to open the files.
 
Brendan MacLean responded:  2017-07-30
Hi Jess and Matt,
I kind-of lost track of this one with everything else going on this summer, but I would like to make sure you are not just stuck on 3.6 indefinitely, Jess.

Has this been fixed for you in Skyline-daily? Matt, any chance we have merged a fix back to the 3.7 release branch for the next patch release, which should be coming very soon.

Thanks.

--Brendan
 
Brendan MacLean responded:  2017-07-30
Oops. I think my mistake. Looking back through the thread on this one, I think we are still waiting on a new library from SCIEX. I have emailed our contact there as well. Still hope we can include a fix in the 3.7 patch release.
 
becker78 responded:  2019-01-15
Hi Brendan,

For the past 18mo we've been running 3.6 on our instrument PC to monitor on-going runs.
However, after a software upgrade (Windows and Analyst) from Sciex we no longer have access to Skyline 3.6.
I've tried both the current release version and daily versions of skyline and still get the previously discussed errors.
I cannot roll back to 3.6 from the version I recently downloaded. Help? Please?

Thanks
Jess