MS1 filtering - library peptide

support
MS1 filtering - library peptide mmr6q  2016-02-17
 
Brendan,
Sorry for the continuing questions.
I generated a spectral library using a Mascot .dat file, which has a high-score match to an 8-residue peptide that contains residue numbers 2-9 in from the protein n-terminus (methionine). When I import the corresponding .raw file, that yielded the .dat file, that peptide is not displayed below the parent protein, despite the peptide settings of 6 AA minimum peptide length and exclude 1 n-terminal AA. This peptide is found in the spectral library explorer, but when I add it from the explorer it appears as a "library" peptide and is not associated with the parent protein (and no RIC is plotted). In addition, this peptide is not included in the long list of possible tryptic peptides shown upon right clicking on the protein in the Targets list. Thank you for any advice you can provide to have that peptide included with the other peptides of that same protein.
Mark
 
 
mmr6q responded:  2016-02-18
Brendan,
Regarding my question about the peptide with a sequence starting at residue #2 in a protein, I found that by removing the Met (residue #1), the peptide then was listed under its protein in the Targets list and was found in the data file. Is there a better way to do this, so that I do not need to do this with every protein? Thank you.
Mark
 
Brendan MacLean responded:  2016-02-18
Hi Mark,
I have posted a TODO issue to the Skyline issues list around more automatic removal of protein N-terminal M, and we will hopefully get to it in the near future:

https://skyline.gs.washington.edu/labkey/issues/home/issues/details.view?issueId=453

Thanks for letting us know this would also be helpful to you. I have heard this request several times over the years.

--Brendan
 
aaron robinson responded:  2019-04-22
Hey Brendan,

Sorry for reviving a dead thread but I ran into this issue today. I couldn't figure out why a peptide that was in my DIA library wasn't appearing in Skyline unless I manually added it using the MS/MS Spectral Library Explorer .

It might be worth fixing this if it is possible...took me a while to figure out what was going on! I thought I was going crazy...

-Aaron
 
aaron robinson responded:  2019-04-22
This was the peptide: (See attached)
 
Brendan MacLean responded:  2019-04-23
Thanks, Aaron, for the update. I added a comment to the bug. Unfortunately, we are a little shorthanded on people to implement small features like this one. Maybe we can get to it after ASMS.

Glad you worked it out, and again thanks for raising the issue to let us know it is still occasionally a pain point.

--Brendan