How to group peptide sequences by peak quality icons

support
How to group peptide sequences by peak quality icons michel.petrovic  2012-09-12
 
Dear Brendan,

If I take for instance the tutorial 'Skyline Targeted Method Refinement' and go to the page 2, I can see the color explanation:

There are peak quality icons, and they indicate:
- Green – All transitions contribute a co‐eluting peak to the peak Skyline picked as the best.
- Yellow – At least half of the transitions contribute a co‐eluting peak.
- Red – Less than half of the transitions contribute a co‐eluting peak.

Our users would like to know if there is a way to view all information in a way that Skyline groups all peaks having a red icon together?
This will really simplify their manual control.

We will have much more protein sequences compared to your examples and this feature will be a must.

Best Regards,
Michel
 
 
Brendan MacLean responded:  2012-09-12
Hi Michel,
I am not sure I quite get what you are asking for. Are you talking about all levels: proteins, peptides, precursors and transitions? Or just proteins and peptides, or just proteins?

Also, the color icons are dependent on which replicate you have active. Red in one run may be green in another.

Let's keep talking about exactly what you are trying to achieve and why this might be useful.

--Brendan
 
michel.petrovic responded:  2012-09-13
Hi Brendan,
 
Please have a look at the attachment which simulate the feature.
 
Best Regards,
Michel
 
Brendan MacLean responded:  2012-09-13
Hi Michel,
Okay, I see what you are suggesting now. It is not sorting actually, but filtering. I can create a TODO issue in the issues list for this, but I can't say exactly when it will make it to the top of our priority list.

One thing you can try that may be useful and provides some support for finding "red dots" is:

- On the Edit menu, click Find
- Click the Show Advanced button, if it is present
- Check the Unintegrated transitions checkbox
- Click the Find All button

This will give you a complete list of transitions without integrated peak areas across all replicates. The "red dots" themselves refer to only one replicate, and change as you change the active replicate, if you have a multi-replicate data set.

Hope this helps. Thanks for sharing your feature request with such a nice mock-up.

--Brendan
 
Brendan MacLean responded:  2012-09-17
I should also mention that when you are not doing method refinement, as described in the Targeted Method Refinement tutorial, you will probably want to have the Settings > Integrate All menu item checked.

When you are working on method refinement, it is useful to know which transitions Skyline felt lacked sufficiently coeluting signal to be included in the peak group. When you are working with an already refined method, we have found that forcing Skyline to integrate all transitions to the boundaries of the most intense peak yields the lowest variance over multiple technical replicates.

Using Integrate All will also get rid of the vast majority of you red dot peak indicators, since they will only appear on transitions where no signal was detected between the integration boundaries.

--Brendan
 
laura corveleyn responded:  2021-04-16
Hi Brendan,

Now, years later, I am also looking to group the peptides in my Skyline document accoring to their peak quality icon (green, orange, red). I was wondering if this feature was implemented yet?

Kind regards,

Laura
 
Brendan MacLean responded:  2021-04-16
Hi Laura,
A lot has been implemented since 2012. You can find this value in the Document Grid as "Peptide Result" -> "Peptide Peak Found Ratio". I wish I had named these values "Proportion" instead of "Ratio". It hasn't seemed important enough to fix, though.

If you add this value to a Document Grid report, then you can sort by it, and know that the colors are based determined by:

green = 1.0
orange >= 0.5 (but not 1.0)
red < 0.5

So, that would allow the grouping you described. If you wanted to group them into separate documents you could use the document grid to select these ranges and the red X (delete) button in the document grid to get rid of the peptides you want to remove, or Edit > Refine > Accept Peptides to remove all but a specific set of peptides you want to keep in a document.

And you can also use File > Import > Document to merge separated documents in a new order, if what you are really trying to achieve is a new ordering in the Targets view.

Hope this gives you some ideas for how to achieve what your are looking for. Thanks for posting to the Skyline support board.

--Brendan
 
laura corveleyn responded:  2021-04-16
Hi Brendan,

This is exactly what I was looking for! Thanks a lot!

Best,

Laura