Skyline does not recognize all peptides identified with MaxQuant

support
Skyline does not recognize all peptides identified with MaxQuant Sven F  2014-08-21
 
Hi, I like to do some quantification of phosphorylated peptides with the Skyline software. For identification I use the MaxQuant software v1.4.1.2 To quantify my data, I import the msms.txt from the MaxQuant search into Skyline. Because I need just the data from one single protein, I erased data of all other proteins from the .txt file. Skyline builds up a peptide library based on the MaxQuant search, but also there are some peptides, which can be found in the library but are not identified by Skyline in the MS spectrum. So there are some phosphorylated peptides identified by MaxQuant but are not found by Skyline. So in the end, MaxQuant gives me a sequence coverage for this protein about 86%, wheras Skyline is approximately at 20%.
I already checked the parameters like modifications ect, but I could not find a solution. Also I tried to import peptide boundaries using a modified verdion of the evidence.txt as described formerly here on this forum, which occurs in an error, saying the peptide could not be found.

I attached the Skyline an msms file so hopefully you can take a look on them.

Thanks a lot.

Best regards,
Sven
 
 
Kaipo responded:  2014-08-21
Hi Sven,
Can you also attach the mqpar.xml file you used and modifications.xml if you used one besides the default?

Thanks,
Kaipo
 
Sven F responded:  2014-08-21
Hi Kaipo,

yes sure, forgot this one. Did not use modifications.xml.

Thanks,
Sven
 
Kaipo responded:  2014-08-21
Hi Sven,
I took a look at the library but didn't notice any obvious problems - could you point me to a line in the msms.txt file where there is a peptide that you expect to see in Skyline but it isn't identified?

Thanks,
Kaipo
 
Sven F responded:  2014-08-22
Hi Kaipo,

yes the library seems good to me, too. The Problem is, that these peptides in the library are not identified in the Raw-Data by Skyline, I suppose. When I hover the cursor in the Skyline interface over the Name of the prtoein on the left side, I see the sequence coverage which is very poor compared to the MaxQuant results. So there are just few peptides I can quantify. For example, almost all peptides located between AA 300 and 400 within the prtoein sequence are not listed by Skyline (but are in the library).
If you open msms.txt even the first 2 peptides AIQIKPSFVR and DAEEVIPSEIVNDDINIGEDYIK are not identified by Skyline and can not be quantified, but are located within the library.

I hope this explanation is now more comprehensible. I wasn't able to find the problem myself.

Thanks.

Best regards,
Sven
 
Brendan MacLean responded:  2014-08-22
Hi Sven,
This is most likely a mismatch between your Skyline settings and the information in your library. Are there modifications in any of these peptides (e.g. Serine phosphorylation)? If you don't define the right modifications in your Peptide Settings - Modifications tab, that is one reason Skyline might recognize identified peptides from your library. Though, in this case, Skyline should alert you to the missing modifications when you open the Spectral Library Explorer, and frequently suggest modifications to define.

Other possible explanations include missed cleavage limit (Peptide Settings - Digestion), Peptide Settings - Filter options that exclude the peptides, or allowed charge states in Transition Settings - Filter.

Not exactly sure what is going on in your case. I might be able to help more if you provide more details, like screenshots of what you are seeing. (use Alt-PrtScn, paste into PowerPoint slides, and attach to a response) The issue is most likely that your settings are causing Skyline to exclude the peptides in your library. Hopefully, between the Spectral Library Explorer and your settings you can figure this out without us, as this was one of the motivations for creating the Spectral Library Explorer, but if not, please give us more to look at on some examples.

Hope this helps. Thanks for your post to the Skyline support board.

--Brendan
 
Brendan MacLean responded:  2014-08-22
Hi Sven,
I should also note that if you were trying to allow Serine phosphorylation, but you forgot to check the "Variable" option on the modification, you could put Skyline in a state where it expects phosphorylation on all Serine residues, which would cause Skyline to exclude all peptides where all Serines are not phosphorylated.

Anyway, again look to your settings. Something is amiss in there.

--Brendan
 
suhongzh5246 responded:  2014-08-22
I have similar problem. I built up libraries from Proteome Discoverer (.msf) into Skyline, only small percentage of peptides showed up in Skyline. I tried different peptide and transition setting as suggested above, no improvement.
 
Sven F responded:  2014-08-22
Hi Brendan,

I tried to figure it out myself by reading threads with similar problems here on this board. Already double-checked the settings, all modifications are set to variable (except carbamidomethylation), tried to re-load the Raw-Data, created new msms.txt and tried to import peak boundaries (which did not work because it says, the first peptide in the evidence.txt doesn't match to any in this document. And yes, I changed the txt to a Skyline compatible form as described here https://skyline.gs.washington.edu/labkey/announcements/home/support/thread.view?rowId=8343).
Also another person in ouir group got trouble with the identification of some peptides identified by MaxQuant, but not by Skyline.

After trying out different settings to get those peptides I could not help me but to write on this board. It is absolutely possible that I overlooked something, but honestly I don't know what it could be :-(.

I attached a ppx with some screens of the problem and also the peptide and transition settings I used.

With other Data I got some good results using Skyline, but especially with this data set it is kind of strange. It was measured using a Thermo Fisher Velos Elite.
If you need any other information please let me know.

Thank you very much for your help!

best regards,
Sven
 
Jarrett Egertson responded:  2014-08-22
Hi Sven,

   Kaipo opened up your document and found that a lot of the peptides that don't match between your spectral library, and background FASTA differ only in a Leucine (L) <--> Isoleucine (I) swap. At a glance, it appears that all of the library spectra have isoleucine, while the background fasta has leucines and isoleucines. Since these two amino acids are isomers, swapping them should not change the theoretical spectrum used in a database search (i.e. the peptide sequence with I or L should match equally well with the observed experimental spectrum). However, I would still expect MaxQuant to output the same amino acid as is in the matching FASTA file. Is the .fasta file you used to generate your background proteome the exact same one as was used in the MaxQuant search? Or is it the case that MaxQuant just always outputs I for a match to I or L? Thanks for posting about this issue on the Skyline board, we are here to help!

Best,
Jarrett
 
Sven F responded:  2014-08-25
Hi,

thank you very much for this hint! That was the problem. I checked my MaxQuant parameter file and there is indeed ine little box checked, which has the consequence that every I or L outputs as an I. I didn't think of this option, beauase normally it is switched off and I never use it. I checked every possibility in Skyline but overlooked this box -.-
I testes it with a new MaxQuant search and now it looks fine.
Thank you very much for your help and patience and sorry for the (unnecessary) circumstances.

Best regards,
Sven
 
sofia ainatzi responded:  2019-12-18
Hi, I ran into a similar problem, quite peculiar though. I ran a peptide search using MaxQuant vs 1.6.2.10, where I configure some new modifications. Afterwards, I used Skyline vs64_4_2_0_18305 to extract MS1 peaks of the peptide of interest. For that, I copy paste the msms.txt and mqpar.xml and modification.xml files into the same folder with the skyline document. Then, I built a spectral library as following: as an input I used the relevant msms.txt, the raw files, I added all the suggested modifications by Skyline (including those that I am interested in), I specified as precursor mass analyzer the orbitrap and last I browsed the same fasta file that I used for the MaxQuant search. Skyline successfully recognizes almost all the peptides except the one that I am particulary interested (how unfortunate). In particular, I set 4 different variable modifications and the peptide of interetsd is found modified with Mod1 or Mod2 separately. However, maxquant has identified the same peptide also modified at the same time by Mod1 and Mod2, but this doubly modified peptide is not recognized by Skyline. I double-checked that I allow for maximum 3 variable modifications in peptide settings. Does anyone have any clue?

Thanks in advance,
Sofia
 
matt.chambers42 responded:  2019-12-18
Hi Sofia,

Can you send us the sky, blib, msms.txt, mqpar.xml, and modification.xml files so we can check this out ourselves?

Thanks,
-Matt
 
sofia ainatzi responded:  2020-01-06
Dear Matt,

here you will find the relevant files attached. I am particulartly interested in the modification of the LIFAGKQLEDGR. This peptide has been identified to be carry the ubiquitin remnant -GG. When labeled with TMTzero, there are two possible sites that can be modified, the Nterminus of the peptide plus the new Nterminus provided by the ubiquitin remnant. I am particularly interested in the LIFAGKggQLEDRG that is fully labeled, meaning that has two TMT labels. For that I configure an additional modification, named as TMT-GG (+338,1954) which is the sum of the individual modifications and ran a MaxQuant search. In the output msms.txt file the doubly labeled LIFAGKggQLEDRG is identified, however is not recognized by Skyline. I am looking forward for your feedback.

Thanks in advance,

Sofia Ainatzi
 
matt.chambers42 responded:  2020-01-13
Hi Sofia,

Thanks for the files. Can you retry your MaxQuant search with the latest version? They changed the way they represent mods in the peptide sequence in msms.txt to make it much easier to parse them unambiguously. The BiblioSpec parser currently depends on the mod names in "_(tm)AK(tm)IQDK(tm)EGIPPDQQR_" (e.g. "(tm)") being unambiguous and with your modifications.xml they are not. That will probably resolve the issue with Skyline but let me know if it doesn't.